APL2/PC display font problem 
Author Message
 APL2/PC display font problem

Responding to msg from: Charles Schulz

Quote:
>Subject: APL2/PC display font problem
>snip.....
>I recently got a new PC with a nice SVGA monitor, so
>thought I could  take advantage of the small display
>font in APL2/PC which I had  not used before.  However
>I ran into weird problems.  IBM APL2 support  did not
>have any suggestions, does anyone else know what's
>going  on here?

>Using APL2/PC 1.02 --

Yeah, I also use APL2/PC ver 1.02 - acquired summer of
93 and used ever since.

Quote:
>At first I couldn't even get the large font to work.
>The APL2FONT  without switches (default) program turns
>the display into a full screen  of gibberish.  APL2FONT
>/T restores the display.

I had same problem when installing APL2/PC on my 486DX
(along with a variety of other problems  - especially with
EMM386 active).  Invoking APL2FONT.COM without any
switches turned my VGA monitor into a "black hole" and
also locked the machine up real tight - cold boot needed to
restart..

Quote:
>I discovered that the /B switch worked.  The manual
>(p.15) says this is  25 line font for an IBM PC or PS/2
>display adapter.  My PC is not an IBM  machine and I do
>not have this adapter.  Actually, my previous machine
>was a PS/2 70 with this adapter, but APL2FONT worked
>without /B there.  (Why does /B work on a non-PS/2, but
>I didn't need in on a PS/2?  Also, /B is only mentioned
>in the manual; "APL2FONT ?" for APL2/PC and  for
>TryAPL2 does not show this switch.  ?)

Back then, I did considerable experimentation with
APL2FONT.COM and the batch file APLON.BAT.
The latter provided code page switching examples that,
after some changes  - both rewriting and renaming APLON
as well as modifying CONFIG.SYS (activating DISPLAY.SYS)
seemed to provide the most reliable way to run APL2.
I just gave up on APL2FONT as too unreliable.  See
later comment.

Quote:
>/S, /H, /E do not work on my new PC (S and H produced
>readable standard  characters -- /S with a small font
>-- but no APL characters).

After your post I went back and experimented again with
APL2FONT with the B, S, and T switches.  B alone
usually worked, but occasionally brought APL2 up with
odd looking "split" lines on my VGA.   T always worked,
S worked maybe 60-70% of time.  When it failed the
machine locked up and screen went black, cold boot
required.  When it worked, the small font appeared, but
like your experience, without  APL glyphs. H switch
locked machine.

Quote:
>I tried using the APL code page support as described in
>appendix E.  I  didn't find any mention of how to
>select the small font.  When I used  MODE CONS LINES=
>it will switch to the small font ONLY for DOS, but when
> I enter APL the session comes up with the large 25
>line font instead.

>??

You might take a look at WSs FONTEDIT and FONTUTIL and
their writeups in Vol I of the 3 ring binder manual,
There is discussion of how to modify APL2FONT.COM.
I tried it, still no luck with /S  - The "weirdness" remains!

Recommendations - Just refuse to mess with APL2FONT.
Instead start APL2 with batch files that use "mode" and
"chcp" commands.  Unfortunately this means living
with the large 25 line APL font.

Re EMM386 and DISPLAY.SYS, I use DOS 6.2 with a
menu setup in CONFIG that boots up 3 options -
(1)do not run APL2 (2)run APL2 from DOS
command line, (3)run APL2 under Windows 3.1.

Lew Robinson



Wed, 17 Sep 1997 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. APL2/PC display font problem

2. APL2/PC Fonts and Windows 2000

3. APL2/PC in DOS Window with Win95 using APL fonts

4. APL2/PC HP Fonts ??

5. Font display problems under Red Hat Linux 7.3

6. Problem of displaying Japanese font on BLT

7. font display problem in IDLE

8. True Type APL2 Font

9. APL2 PostScript Fonts

10. APL2 Fonts for Exceed

11. Downloading an APL2 font to an HP4M *HELP*

12. How display APL characters in IBM APL2

 

 
Powered by phpBB® Forum Software