Debugging is erratic in evC++ 3.0 
Author Message
 Debugging is erratic in evC++ 3.0

Has anyone ever had the following problem? I'm trying to
debug an application running on a NEC MobilePro 790 (HPC
2000).

I'm connected to the device from my laptop using an
ethernet connection.

When I try to step through the program the line position
sometimes moves backwards in the program and sometimes
skips lines.

Also, the variable values shown in locals and watch are
not always correct. I've had to insert message boxes in
order to see the true value of variables.

If anyone has seen this and knows what I'm doing wrong,
please let me know.

Thanks! D. Arnold



Wed, 21 Sep 2005 03:25:14 GMT  
 Debugging is erratic in evC++ 3.0
Sounds like you're trying to debug a release build.  Compiler optimizations
really throw the de{*filter*} and symbolic information.

You'll have much better luck debugging a debug build.  If you have to debug
retail, you'll have to rely on disassembly mode and looking at the
instructions there.  And some "stack" variables will actually be placed in
registers, so pay attention to that.

--

Michael Salamone
Entrek Software, Inc.
www.entrek.com


Quote:
> Has anyone ever had the following problem? I'm trying to
> debug an application running on a NEC MobilePro 790 (HPC
> 2000).

> I'm connected to the device from my laptop using an
> ethernet connection.

> When I try to step through the program the line position
> sometimes moves backwards in the program and sometimes
> skips lines.

> Also, the variable values shown in locals and watch are
> not always correct. I've had to insert message boxes in
> order to see the true value of variables.

> If anyone has seen this and knows what I'm doing wrong,
> please let me know.

> Thanks! D. Arnold



Thu, 22 Sep 2005 06:39:57 GMT  
 Debugging is erratic in evC++ 3.0
Thanks Michael. I turned off the optimizations and things
are now a lot better.


Sat, 24 Sep 2005 05:02:42 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Debugging Erratic in eVC++ 3.0

2. eVC++ 3.0: debugging DLL

3. PPC 2002, WinCE 3.0, eVC++ 3.0, loading images in HTML viewer control

4. eVC++ 3.0 and eVC++ 4.0

5. Problems with debugging EVC 3.0, and VC 6.0

6. compatibility eVC++ 3.0 and eVC++4.0?

7. evc 3.0 & adoce 3.0

8. eVC 4.0 vs. eVC 3.0 - platform compatibility

9. Static eVC 3.0 library compatible with eVC 4.0?

10. Using EVC 4.0 linker/compiler BIN with EVC 3.0

11. Running eVC++ 3.0 apps on a WIndows CE 4.1 device

12. eVC++ 3.0 and MFC

 

 
Powered by phpBB® Forum Software