Link Error porting TAPI app to CE.NET 
Author Message
 Link Error porting TAPI app to CE.NET

I've just upgraded to CE.NET and am trying to port an eVC3 project.

All of my TAPI function calls are generating an unresolved external symbol
link error (LNK2019).

I think this is something simple and basic to fix, but I just can't seem to
locate the problem.

Would anyone like to clue me in as to what I'm doing wrong?

TIA,
Susan



Mon, 26 Sep 2005 22:29:58 GMT  
 Link Error porting TAPI app to CE.NET
Search past NG articles (deja.com.)  There are serious issues trying
to use TAPI from .NET.
--
Grant Schenck
Grant Schenck Software

http://schenck.150m.com


Quote:
> I've just upgraded to CE.NET and am trying to port an eVC3 project.

> All of my TAPI function calls are generating an unresolved external
symbol
> link error (LNK2019).

> I think this is something simple and basic to fix, but I just can't
seem to
> locate the problem.

> Would anyone like to clue me in as to what I'm doing wrong?

> TIA,
> Susan



Mon, 26 Sep 2005 22:45:09 GMT  
 Link Error porting TAPI app to CE.NET
Hi Grant,

I've noticed quite a few articles on the subject, and am leaning towards
implementing the AT commands instead of using TAPI.  But since this is a
'simple' application (dial the phone, establish the connection, transfer
data using the serial port, hangup the phone), I was  hoping that TAPI would
be sufficient.

At this point I would just like to get the darn app linked so I can see what
kind of damage has been done upgrading to CE.NET.

Susan


Quote:
> Search past NG articles (deja.com.)  There are serious issues trying
> to use TAPI from .NET.
> --
> Grant Schenck
> Grant Schenck Software

> http://schenck.150m.com



> > I've just upgraded to CE.NET and am trying to port an eVC3 project.

> > All of my TAPI function calls are generating an unresolved external
> symbol
> > link error (LNK2019).

> > I think this is something simple and basic to fix, but I just can't
> seem to
> > locate the problem.

> > Would anyone like to clue me in as to what I'm doing wrong?

> > TIA,
> > Susan



Mon, 26 Sep 2005 22:52:14 GMT  
 Link Error porting TAPI app to CE.NET
I am having the same link problem, I cannot find
Tapi32.lib that will work with eVC4 compiler.  Has anyone
found a solution?

David C.

Quote:
>-----Original Message-----
>Hi Grant,

>I've noticed quite a few articles on the subject, and am
leaning towards
>implementing the AT commands instead of using TAPI.  But
since this is a
>'simple' application (dial the phone, establish the

connection, transfer
Quote:
>data using the serial port, hangup the phone), I was  

hoping that TAPI would
Quote:
>be sufficient.

>At this point I would just like to get the darn app

linked so I can see what
Quote:
>kind of damage has been done upgrading to CE.NET.

>Susan



>> Search past NG articles (deja.com.)  There are serious
issues trying
>> to use TAPI from .NET.
>> --
>> Grant Schenck
>> Grant Schenck Software

>> http://schenck.150m.com



>> > I've just upgraded to CE.NET and am trying to port an
eVC3 project.

>> > All of my TAPI function calls are generating an
unresolved external
>> symbol
>> > link error (LNK2019).

>> > I think this is something simple and basic to fix,
but I just can't
>> seem to
>> > locate the problem.

>> > Would anyone like to clue me in as to what I'm doing
wrong?

>> > TIA,
>> > Susan

>.



Sun, 02 Oct 2005 02:25:16 GMT  
 
 [ 4 post ] 

 Relevant Pages 

1. porting my app from ppc2002 to Windows CE .NET

2. Linking error 2019 unresolved external symbol _main when porting to .NET

3. Error Linking TAPI functions

4. Help!!!About Tapi Link Error

5. Parallel Port Printing on CE.NET

6. 4 Serial ports in CE.NET

7. MFC App with Platform Builder 4.0/Windows CE .NET

8. CE .NET ARM4I Compiler Error - known bug?

9. SQL Server CE 2.0, EVC++4, and CE.NET

10. CE 3.0 application in CE.NET platform

11. ADOCE and SQL CE on NetPad 5000 (Ce.net)

12. SQL Server CE, CE.NET and eVC++ 4

 

 
Powered by phpBB® Forum Software