Number of Copies Not Working 
Author Message
 Number of Copies Not Working

VC++ 6, SDI project

I've had a user recently encounter a problem using the "Number of
Copies" feature in the Print dialog box.  (He's trying to print
multiple copies)

When he sets the value to print multiple copies, he says it works fine
with one printer, yet on another (Canon BJC 240) it only prints one
copy.  I made a simple test program that did nothing more than print a
single line on a page and had him try it out.  The results were the
same.

Is there something I'm missing or need to add to get "Number of
Copies" working properly in an MFC project or might this be a bad
printer driver?

Jack



Sun, 11 Sep 2005 05:20:16 GMT  
 Number of Copies Not Working

Quote:
>Is there something I'm missing or need to add to get "Number of
>Copies" working properly in an MFC project or might this be a bad
>printer driver?

Jack,

Seeing that it's a Canon printer, I'd certainly suspect the driver ;)

Try the same test on a variety of different printer (manufacturers)
and see if any others have the same problem as the Canon driver.

Dave
--
MVP VC++ FAQ: http://www.mvps.org/vcfaq



Sun, 11 Sep 2005 09:53:59 GMT  
 Number of Copies Not Working
It could be that the BJC 240 doesn't implement multiple copies on the
printer itself (like more expensive printers do). If that's the case,
you have to handle multiples copies using software (i.e. send the job X
number of times). There a way to figure out if the printer handles
multiple copies or not in one of structures related the printer.

--Russell

Quote:

> VC++ 6, SDI project

> I've had a user recently encounter a problem using the "Number of
> Copies" feature in the Print dialog box.  (He's trying to print
> multiple copies)

> When he sets the value to print multiple copies, he says it works fine
> with one printer, yet on another (Canon BJC 240) it only prints one
> copy.  I made a simple test program that did nothing more than print a
> single line on a page and had him try it out.  The results were the
> same.

> Is there something I'm missing or need to add to get "Number of
> Copies" working properly in an MFC project or might this be a bad
> printer driver?

> Jack



Thu, 15 Sep 2005 02:38:45 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. String copying not working?

2. Subclassed copy constructor not working

3. Copy/Paste using Ctrl+C/Ctrl+V does not work in CHtmlView Class

4. Copy/Paste via keyboard not working in FormView

5. Rich Edit cut/copy does not work?

6. copy does not work

7. counting number of lines in a file(not home work)

8. Random numbers not working

9. C++/ATL/ADO - Intellisense not working (statement completion options) not working

10. this code works on SGI does not work on linux

11. CMap Lookup not working (at least I cannot get it to work)

12. Program not work at release mode but work at debug mode

 

 
Powered by phpBB® Forum Software