MFC app crashes using new VC 6.0 libraries 
Author Message
 MFC app crashes using new VC 6.0 libraries

I have an MFC app that I developed using VC5.  The app has always and still
does run fine under WinNT.  The problem occurs with Win95.

When I originally shipped the app, it would crash under Win95.  My customer
was able to download some sort of Win95 updater from Microsoft, and this
fixed the problem.

I then upgraded to VC6.  I shipped my app with the newer MFC42.DLL.  This
one is version 6.00.8168.0, dated 9/18/98.  Now, when my customer tries to
run the app on Win95 it crashes with a page fault in MFC42.DLL.

Here are some extra details which may help:

* I am accessing MS SQL Server 6.5 via ODBC
* I am placing the newer MFC42.DLL in my program directory when I install.

Any ideas?  Thanks :-)

David Calkins
New River Kinematics



Tue, 20 Mar 2001 03:00:00 GMT  
 MFC app crashes using new VC 6.0 libraries

Quote:
>I then upgraded to VC6.  I shipped my app with the newer MFC42.DLL.  This
>one is version 6.00.8168.0, dated 9/18/98.  Now, when my customer tries to
>run the app on Win95 it crashes with a page fault in MFC42.DLL.

David,

Have you also shipped the updated msvcrt.dll, and all other relevant
redistributables that your application uses?

Dave Lowndes
----
My address is altered to discourage junk mail.
Please post responses to the newsgroup thread,
there's no need for follow-up email copies.



Wed, 21 Mar 2001 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. opengl enabled view crashing in nt2000 MFC MDI VC 6.0 app

2. Help w/ app crashing in MFC shared dll but not w\ static MFC using VC6

3. App ran using 4.2, crashes with 6.0

4. Memory Allocation using MFC App and DLL with shared MFC library

5. VC 6.0 MFC Library Installer

6. Unfixed: Apps linked with MFC DLL and using CHtmlView crash on close under WinXP

7. Unfixed: Apps linked with MFC DLL and using CHtmlView crash on close under WinXP

8. VC 4.2 link error linking static libraries from VC 6.0

9. Using placement new in an MFC app

10. Still problems with linking library function with windows app using MFC

11. Using IJG Jpeg Library in MFC App

12. Problem to convert from VC 6.0 to VC 7.1 because of using filebuf::setmode()

 

 
Powered by phpBB® Forum Software