Q: CDialog::DoModal fails 
Author Message
 Q: CDialog::DoModal fails

On Wed, 23 Jul 1997 15:55:47 +0200, Juha Kontiainen

Quote:

>Could someone please tell me what I may be doing wrong
>if CDialog::DoModal returns -1, i.e. fails.

Add a call to GetLastError after DoModal fails.  At least it'll give
you some more (hopefully useful) information.

Don



Sun, 09 Jan 2000 03:00:00 GMT  
 Q: CDialog::DoModal fails

Could someone please tell me what I may be doing wrong
if CDialog::DoModal returns -1, i.e. fails. The first time
everything succeeds but any attempt to redisplay the dialog
via another DoModal fails. Everything used to work fine earlier
on but without any code modifications on my part things just
started working in the above manner.
I would greatly appreciate any hints regarding what I may be
doing wrong,

                Juha Kontiainen

I am using Windows NT 4.0 and Visual C++ 4.2 Enterprise edition.



Sun, 09 Jan 2000 03:00:00 GMT  
 Q: CDialog::DoModal fails


Fri, 19 Jun 1992 00:00:00 GMT  
 Q: CDialog::DoModal fails

You're going to have to supply more information than that if you want any
useful help. How about the minimal source code that exhibits the behaviour?
--
Richard Lewis Haggard
Haggard & Associates, International

--------------------------------------------------------
I have a photographic memory but I seem to have misplaced the film.



Mon, 10 Jan 2000 03:00:00 GMT  
 Q: CDialog::DoModal fails


Fri, 19 Jun 1992 00:00:00 GMT  
 Q: CDialog::DoModal fails

Quote:

> Could someone please tell me what I may be doing wrong
> if CDialog::DoModal returns -1, i.e. fails. The first time
> everything succeeds but any attempt to redisplay the dialog
> via another DoModal fails. Everything used to work fine earlier
> on but without any code modifications on my part things just
> started working in the above manner.
> I would greatly appreciate any hints regarding what I may be
> doing wrong,

>                 Juha Kontiainen

> I am using Windows NT 4.0 and Visual C++ 4.2 Enterprise edition.

 Hi,

Before calling another DoModal call destructor and construct again ( as
dialog is already in memory). I think it wiil solve your problem.



Fri, 14 Jan 2000 03:00:00 GMT  
 
 [ 6 post ] 

 Relevant Pages 

1. Q: CDialog::DoModal () fails

2. Help. CDialog::DoModal Fail in _beginthreadex

3. CDialog::DoModal(), CDialog::EndDialog() Design Flaw

4. Q: How to move a CDialog before calling DoModal()

5. CDialog::DoModal

6. Using DoModal from CDialog when called from a DLL

7. CDialog.DoModal problem

8. CDialog::DoModal() Behaviour

9. Invalid Page Fault from CDialog.DoModal()

10. Calling CDialog::DoModal crashes

11. CDialog::DoModal()

12. CDialog::DoModal() keyboard messages?????

 

 
Powered by phpBB® Forum Software