Meda Control to network program - does not execute 
Author Message
 Meda Control to network program - does not execute

Hello,

   I am trying add a Windows Meda Player ActiveX control to an pre-
existing network application in Visual C++ 6.0 and application is not
executing.

A screen shot of this application is available at :
http://www.*-*-*.com/

Problem:  When I delete the member variable associated with the Media
Player control the networking application works just fine(the program
is a very simple chatting program). It runs with no code in the buttons
labeled "Play Sound" and "Stop Sound" and even runs with no errors when
the Media Player is on the dialog without any code or variables
attached.  The problem is that when I add a memeber variable named
m_ctlMediaPlayer the program compiles, but does not run.  Have I added
to many things to to dialog (please see about URL)?  Have I used up to
many resources?  Is there some sort of conflict with the use of sockets
and the windows media player in the same application?  If someone
knowledgable in this area could help me out I would appreciate it.

Thanks in adance,

Andy

Sent via Deja.com http://www.*-*-*.com/
Before you buy.



Thu, 02 Jan 2003 03:00:00 GMT  
 Meda Control to network program - does not execute
If you could tell us where it stops running, or what error messages appear
you might get more of a response...


Quote:
> Hello,

>    I am trying add a Windows Meda Player ActiveX control to an pre-
> existing network application in Visual C++ 6.0 and application is not
> executing.

> A screen shot of this application is available at :
> http://web.mit.edu/ananda/www/media_sock.jpg

> Problem:  When I delete the member variable associated with the Media
> Player control the networking application works just fine(the program
> is a very simple chatting program). It runs with no code in the buttons
> labeled "Play Sound" and "Stop Sound" and even runs with no errors when
> the Media Player is on the dialog without any code or variables
> attached.  The problem is that when I add a memeber variable named
> m_ctlMediaPlayer the program compiles, but does not run.  Have I added
> to many things to to dialog (please see about URL)?  Have I used up to
> many resources?  Is there some sort of conflict with the use of sockets
> and the windows media player in the same application?  If someone
> knowledgable in this area could help me out I would appreciate it.

> Thanks in adance,

> Andy

> Sent via Deja.com http://www.deja.com/
> Before you buy.



Fri, 03 Jan 2003 03:00:00 GMT  
 Meda Control to network program - does not execute


Quote:
> If you could tell us where it stops running, or what error messages
appear
> you might get more of a response...

Fair enough.  Sorry about not being clearer before:
My problem is that the project compiles perfectly ...  when I press
control-F5 to compile and execute my project(screen shot available at
below URL) I recieve the expected message

"One or more files are out of date or do not exist.
These files need to be built:
.\Debug\Sock.exe
.\Debug\SockDlg.obj

Would you like to build them?

Yes No  Cancel

"
Then I hit yes and the following appears in my debug screen:

"--------------------Configuration: Sock - Win32 Debug------------------
--
Compiling...
SockDlg.cpp
Linking...

Sock.exe - 0 error(s), 0 warning(s)"

But no program executes.  Now if I hit Control-F5 again(the execute
command) NOTHING happens.  That is my problem.  The file does not
execute, but compiles fine.

If I follow these steps the program will compile and execute fine, but
without the Windows Media Player member variable, which I need to
control the Media Player.

1.  Right click on the Windows Media Player(WMP)
2.  Select class wizard
3.  Select member variables
4.  Select IDC_MEDIAPLAYER1 and delete the m_ctlMediaPlayer variable
that existed previously.
5.  Hit OK to save the changes and hit control-F5.
The program compiles, and executes perfectly.

NOTE:  I have not called any methods on the WMP activex control so
everything compiles when the m_ctlMediaPlayer variable was taken out.

Quote:



> > Hello,

> >    I am trying add a Windows Meda Player ActiveX control to an pre-
> > existing network application in Visual C++ 6.0 and application is
not
> > executing.

> > A screen shot of this application is available at :
> > http://web.mit.edu/ananda/www/media_sock.jpg

> > Problem:  When I delete the member variable associated with the
Media
> > Player control the networking application works just fine(the
program
> > is a very simple chatting program). It runs with no code in the
buttons
> > labeled "Play Sound" and "Stop Sound" and even runs with no errors
when
> > the Media Player is on the dialog without any code or variables
> > attached.  The problem is that when I add a memeber variable named
> > m_ctlMediaPlayer the program compiles, but does not run.  Have I
added
> > to many things to to dialog (please see about URL)?  Have I used up
to
> > many resources?  Is there some sort of conflict with the use of
sockets
> > and the windows media player in the same application?  If someone
> > knowledgable in this area could help me out I would appreciate it.

> > Thanks in adance,

> > Andy

> > Sent via Deja.com http://www.deja.com/
> > Before you buy.

Sent via Deja.com http://www.deja.com/
Before you buy.


Sat, 04 Jan 2003 03:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Functions of Program do not execute properly

2. Need Help Executing Program (suggestions from group added but not quite there yet)

3. How can I execute a program with activeX not registered in the target computer

4. My program will not execute main!

5. can not execute the program in evc++

6. socket programming problem (network not reachable)

7. socket programming problem (network not reachable)

8. could not execute: path not found(Win32 error 3)

9. doing the same as network monitor

10. Problem executing on non mapped network drive

11. Error: network not present or not started

12. Can't execute from Network Drive

 

 
Powered by phpBB® Forum Software