Bitmaps don't work 
Author Message
 Bitmaps don't work

Hi,

I've added bitmap images to my calculator program and this makes the program
crash. I know I'm creating them properly because I created a simple dialog
program with one button and it worked. The button has a number 7 in blue,
and when clicked on it turns into a red 7.
So I went to my calculator program, followed the exact same steps for the
number 7, and I get a "Debug Assertion Failed" message. My McAfee Crash
Monitor says "Exception: Access Violation".

Would anyone know what this message means and if it's easy to fix.

Thanks



Fri, 14 Feb 2003 03:00:00 GMT  
 Bitmaps don't work

Quote:

> Hi,

> I've added bitmap images to my calculator program and this makes the program
> crash. I know I'm creating them properly because I created a simple dialog
> program with one button and it worked. The button has a number 7 in blue,
> and when clicked on it turns into a red 7.
> So I went to my calculator program, followed the exact same steps for the
> number 7, and I get a "Debug Assertion Failed" message. My McAfee Crash
> Monitor says "Exception: Access Violation".

> Would anyone know what this message means and if it's easy to fix.

> Thanks

It means you have a bug in your program and should run it in the de{*filter*} to
investigate.  An Access Violation occurs when your progam attempts to read or
write to a memory location that does not belong to it.  

--
Scott McPhillips [VC++ MVP]



Fri, 14 Feb 2003 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Bitmaps don't work

2. ACCELERATOR KEYS DON'T WORK WITH OnKeyDown BUT WORK WHEN SPY++ IS RUNNING

3. HREF's to .exe's don't work

4. Bitmaps don't load on some machines

5. tree control don't display the 256 color bitmaps

6. Bitmaps don't load on some machines

7. Don't know why this doesn't work, but

8. Help Wnet API's don't seem to work under WINNT Service Control Manager

9. MIDL2361 error - [vararg] with [optional] parameters don't work in VC++ .NET

10. VC7.0: class template using declarations don't work

11. Discovered the root of my problem...Why don't RichEditControls work on .NET

12. outportb: why don't work?

 

 
Powered by phpBB® Forum Software