link error porting project file from old version to VC 6.0 
Author Message
 link error porting project file from old version to VC 6.0

I tried to build this project in VC 6.0,
it gave me this:
LINK : fatal error LNK1104: cannot open file "mfc42ud.lib"

I would think this file belonges to VC4.2 etc.
so how I can solve this ?

Sent via Deja.com http://www.*-*-*.com/
Before you buy.



Sun, 28 Jul 2002 03:00:00 GMT  
 link error porting project file from old version to VC 6.0

Quote:

>I tried to build this project in VC 6.0,
>it gave me this:
>LINK : fatal error LNK1104: cannot open file "mfc42ud.lib"

>I would think this file belonges to VC4.2 etc.

It does belong to the current VC, as it's a MFC library.  They havn't
changed the DLL name in a few versions, which is where the confusion
lies.

Quote:
>so how I can solve this ?

Does the file exist on your system ?  Have a look for it.  It seems
like you are building the UNICODE version of the application, which
means you'll have to install the UNICODE libraries.  

As the project was ported from an older version of VC, that probably
had the UNICODE stuff installed, VC doesn't care if you havn't got it
installed, as the project file thinks you have.

Jim M



Mon, 29 Jul 2002 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. VC 4.2 link error linking static libraries from VC 6.0

2. VC ++ 6.0 problem with older project from 5.0

3. Link Errors in VC.net that don't appear in VC 6.0

4. probably an old question, vc++ 6.0 errors

5. Problem porting ATL project from VC++ 6.0 to VC++.NET 2003

6. VC 6.0 Link error

7. Error while linking on VC 6.0

8. DLL Linking error (VC project problem)

9. Debugging VC 6.0 Project under VC 5.0

10. Using version 6 MFC and VC runtimes on a VC.Net project

11. Old VC 1.52 16bit projects

12. VC 6.0 -> VC 5.0 Error

 

 
Powered by phpBB® Forum Software