Post-build step slow to get rolling 
Author Message
 Post-build step slow to get rolling

I have a project with a post-build step that invokes nmake.  When I
build the project, things go along smoothly until I hit the post-build
step.  After I see the Post-build Description, I have to wait 20-25
seconds before I see any output from nmake.  Does anyone have any ideas
why this is so slow?

Incidentally, it doesn't appear to matter what the command is.  I
replaced the call to nmake with a simple call to "dir" and still got the
delay.  I also tried adding the makefile to the project and invoking
nmake on it as part of a custom-build step for that file.  Still the
long delay.  DOS shells come up quickly and I don't have anything fancy
in my autoexec.bat file.

I'm using VC5 under 95 on a 233MHz machine with 96MB RAM.  Not a
screamer but should be faster than that.  On a 333MHz NT box there's no
appreciable delay at all though.

Any ideas would be appreciated.

thanks,
Marco
--

Piper Creek Software Ltd.       ph:    1.403.234.8686
Calgary Alberta Canada          fax:   1.403.265.4514



Fri, 02 Mar 2001 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. VC6 IDE Hangs at start of post-build step

2. Post-build step

3. Windows Locks Up During The Post-Build Step

4. Pre-clean step in VC Project (like Post-build)

5. HELP! Post-Build Steps Disappearing

6. Visual C++ post-build steps run with an unusual PATH

7. Post-build step

8. Post Build step problem

9. Post-Build step in Visual C++ 5.0

10. Post Build Step

11. Problem with post-build steps

12. VC++ 6.0 SLOW SLOW SLOW SLOW SLOW SLOW

 

 
Powered by phpBB® Forum Software