class view blues 
Author Message
 class view blues

I have a workspace, divided into 20 projects. In the class view I can
see all classes, but when I double-click members, I randomly get a
message: "Cannot find the definition (implementation) of this function"
or " ... defintion for this variable"

This seems always to be the case with protected and private members (is
there an option to avoid this?), and randomly on public members as well
with no appearent reason.

I use VC6/SP3 and it seems this behaviour has been like this since the
beginning of VC5/6.



Sat, 24 Nov 2001 03:00:00 GMT  
 class view blues
Delete the .ncb file in your workspace root.
It'll solve all kinds of problems related to classview
and classwizard!


Sat, 24 Nov 2001 03:00:00 GMT  
 class view blues
It's probably a good idea to periodically delete your .NCB file.  It seems
to get corrupted quite easily.  Especially of your adding/removing files in
a team environment.

-Andy


Quote:
> Delete the .ncb file in your workspace root.
> It'll solve all kinds of problems related to classview
> and classwizard!



Sat, 24 Nov 2001 03:00:00 GMT  
 class view blues
Deleting .NCB file is a good idea.If it still doesn't work check your .clw
file attributes also. Some times you will get problems when it is read only.
Change the Read only attribute.

-Vijay

~~~~~~~~~~~~~~~
Vijay Kumar Reddy
www.E-Supportpoint.com


Quote:
> It's probably a good idea to periodically delete your .NCB file.  It seems
> to get corrupted quite easily.  Especially of your adding/removing files
in
> a team environment.

> -Andy



> > Delete the .ncb file in your workspace root.
> > It'll solve all kinds of problems related to classview
> > and classwizard!



Sun, 25 Nov 2001 03:00:00 GMT  
 class view blues
.ncb deleted, .clw deleted - still nogo :-((

in another thread somebod stated that moving all .dsp files to the same
dir where .dsw resides will help to solve some other strange issues. has
anybody experience if this could help here, too? this is a large
workspace (which works ok, apart from the class view thingy)  and
reordering projects might be some work.

thanks



Fri, 30 Nov 2001 03:00:00 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. class view blues

2. dynamic class view and macro blues

3. VC++: Pink and Blue icons in Class View???

4. VC++: Pink and Blue icons in Class View???

5. How to view classes in class view

6. Blue screen blues

7. Blue on Blue

8. Blue on Blue II

9. VC7 Class View vs Source View synchro. broken

10. Create mutiple views of one document using different view classes

11. i use Visual c++.net,when i view Class view ,my computer always death

12. Create mutiple views of one document using different view classes

 

 
Powered by phpBB® Forum Software