vc.net classview broken 
Author Message
 vc.net classview broken

I have been using C++ in VC.Net for about 2 weeks.  The class view (which i
use very often) works fine at first, but after a little use it slowly stops
working.  The classes stay up to date, but when i double click on a function
declaration or variable name in the class view the IDE doesn't loads the
file but does not go to the function declaration at all.

Whats odd is intellisense (auto complete, parameter info and what not) seem
to work fine.  So does the bar above the source file, which allows me to
select the function i want to go to in the source file.  But the classview
simply will not work.

So far my only solution to this is to delete my profile (i.e erase my user
name and files) and create it again.  Then the class view starts working
again.

Deleting the .ncb file doesn't help.

I also find that vc.net will either sit there for a while using all my cpu,
or hang when trying to access functions or classes through the class view.

This is terribly annoying since this feature worked quite fine (with the
exception of templates) in vc6.

If anybody has had this problem, assitance would be greateful.

I have tried a reinstall of both os and vs.net without any success.  THe
only thing that seems to work is to backup my profile files while it is
working then restore them when it breaks.  This takes too long and should
not be required.



Sat, 18 Sep 2004 10:32:25 GMT  
 vc.net classview broken
There is an issue with code outlining and browsing from class view and
context menus. Do you have code outlining enabled? Does disabling it help?

Thanks,
Tarek


Quote:
> I have been using C++ in vc.net for about 2 weeks.  The class view (which
i
> use very often) works fine at first, but after a little use it slowly
stops
> working.  The classes stay up to date, but when i double click on a
function
> declaration or variable name in the class view the IDE doesn't loads the
> file but does not go to the function declaration at all.

> Whats odd is intellisense (auto complete, parameter info and what not)
seem
> to work fine.  So does the bar above the source file, which allows me to
> select the function i want to go to in the source file.  But the classview
> simply will not work.

> So far my only solution to this is to delete my profile (i.e erase my user
> name and files) and create it again.  Then the class view starts working
> again.

> Deleting the .ncb file doesn't help.

> I also find that vc.net will either sit there for a while using all my
cpu,
> or hang when trying to access functions or classes through the class view.

> This is terribly annoying since this feature worked quite fine (with the
> exception of templates) in vc6.

> If anybody has had this problem, assitance would be greateful.

> I have tried a reinstall of both os and vs.net without any success.  THe
> only thing that seems to work is to backup my profile files while it is
> working then restore them when it breaks.  This takes too long and should
> not be required.



Sun, 19 Sep 2004 06:32:08 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Small namespace/classview bug in VC.NET?

2. VC++.NET source browser broken???

3. Challenge/Help VB.NET VC++.NET VC++6.0

4. Slower compilation with VC Net 2003 (7.1) when compared to VC Net 7.0

5. ClassView breaks - list of classes empty

6. ClassView and folders - Still broken?

7. ClassView and folders - Still broken?

8. ClassView is broken.

9. ClassView is broken.

10. ClassView broken

11. 6.0 ClassView broken

12. ClassView is broken.

 

 
Powered by phpBB® Forum Software