ClassView, Wizardbar and Intellisense do NOT work 
Author Message
 ClassView, Wizardbar and Intellisense do NOT work

ARRRA!!!!!!!!!!!!!!!!!

i tried everything(loading my old code, use the MFC wizard to generate code,
write my own try other ppl's code etc.) the classview does not show
*ANYTHING*. well in *one* project, it showed the functions and variables of
*one* .cpp but does not show the other one's functions/variables, , and in
another project it worked once and that's it, in other projects it doesn't
work at all, same thing with the wizardbar, and IntelliSense works
*SOMETIMES*, this is just soooo odd, i tried reinstalling it but still
doesn't work, i am really frustrated PLEASE HELP!!!!!!!!!!!!!!!!!!

thanks



Thu, 24 May 2001 03:00:00 GMT  
 ClassView, Wizardbar and Intellisense do NOT work
on by the way i'm using Visual C++ 6.0 Professional

Quote:

>ARRRA!!!!!!!!!!!!!!!!!

>i tried everything(loading my old code, use the MFC wizard to generate
code,
>write my own try other ppl's code etc.) the classview does not show
>*ANYTHING*. well in *one* project, it showed the functions and variables of
>*one* .cpp but does not show the other one's functions/variables, , and in
>another project it worked once and that's it, in other projects it doesn't
>work at all, same thing with the wizardbar, and IntelliSense works
>*SOMETIMES*, this is just soooo odd, i tried reinstalling it but still
>doesn't work, i am really frustrated PLEASE HELP!!!!!!!!!!!!!!!!!!

>thanks



Thu, 24 May 2001 03:00:00 GMT  
 ClassView, Wizardbar and Intellisense do NOT work
Visual C++ 6.0 Professional Edition
WIN95 osr1

ARRRA!!!!!!!!!!!!!!!!!

i tried everything(loading my old code, use the MFC wizard to generate code,
write my own try other ppl's code etc.) the classview does not show
*ANYTHING*. well in *one* project, it showed the functions and variables of
*one* .cpp but does not show the other one's functions/variables, , and in
another project it worked once and that's it, in other projects it doesn't
work at all, same thing with the wizardbar, and IntelliSense works
*SOMETIMES*, this is just soooo odd, i tried reinstalling it but still
doesn't work, maybe classview doesn't scan my files???????i am really
frustrated PLEASE HELP!!!!!!!!!!!!!!!!!!

thanks



Fri, 25 May 2001 03:00:00 GMT  
 ClassView, Wizardbar and Intellisense do NOT work
well.... it worked again but the view is not updated when i deleted/added
functions, now i'm certain that this "dynamic parser" vc6 uses does not scan
my source code most of the time... just sometimes the parser works, the only
thing i can find is that if i reload VC6 and start a fresh project, it works
until i add a "class" and it stops working after that no matter whatever i
do(reload vc, reload project etc).....
this is weird

Quote:

>Visual C++ 6.0 Professional Edition
>WIN95 osr1

>ARRRA!!!!!!!!!!!!!!!!!

>i tried everything(loading my old code, use the MFC wizard to generate
code,
>write my own try other ppl's code etc.) the classview does not show
>*ANYTHING*. well in *one* project, it showed the functions and variables of
>*one* .cpp but does not show the other one's functions/variables, , and in
>another project it worked once and that's it, in other projects it doesn't
>work at all, same thing with the wizardbar, and IntelliSense works
>*SOMETIMES*, this is just soooo odd, i tried reinstalling it but still
>doesn't work, maybe classview doesn't scan my files???????i am really
>frustrated PLEASE HELP!!!!!!!!!!!!!!!!!!

>thanks



Fri, 25 May 2001 03:00:00 GMT  
 ClassView, Wizardbar and Intellisense do NOT work
    ClassView should scan off header files which are added to the project.

--
Truth,
   James [MVP]
http://www.NJTheater.Com       -and-
http://www.NJTheater.Com/JamesCurran

Quote:

>>i tried everything(loading my old code, use the MFC wizard to generate
>code,
>>write my own try other ppl's code etc.) the classview does not show
>>*ANYTHING*. well in *one* project, it showed the functions and variables
of
>>*one* .cpp but does not show the other one's functions/variables, , and in
>>another project it worked once and that's it, in other projects it doesn't
>>work at all, same thing with the wizardbar, and IntelliSense works
>>*SOMETIMES*, this is just soooo odd, i tried reinstalling it but still
>>doesn't work, maybe classview doesn't scan my files???????i am really
>>frustrated PLEASE HELP!!!!!!!!!!!!!!!!!!

begin 666 James M. Curran.vcf


M4DLZ.SLQ."!*;VAN(%-T+"!3=6ET92 R0CM";&]O;69I96QD.TY*.S W,# S
M+34Q-#D-"DQ!0D5,.U=/4DL[14Y#3T1)3D<]455/5$5$+5!224Y404),13HQ
M."!*;VAN(%-T+"!3=6ET92 R0CTP1#TP04)L;V]M9FEE;&0L($Y*(# W,# S
M+34Q-#D-"E523#IH='1P.B\O=W=W+DY*5&AE871E<BYC;VTO2F%M97-#=7)R
M86X-"E523#IH='1P.B\O=W=W+DY*5&AE871E<BYC;VT-"D5-04E,.U!2148[
M24Y415).150Z2F%M97-#=7)R86Y 0V]M<'5397)V92YC;VT-"E)%5CHQ.3DX

`
end


Sat, 26 May 2001 03:00:00 GMT  
 ClassView, Wizardbar and Intellisense do NOT work
nope

Quote:

>    ClassView should scan off header files which are added to the project.

>--
>Truth,
>   James [MVP]
>http://www.NJTheater.Com       -and-
>http://www.NJTheater.Com/JamesCurran


>>>i tried everything(loading my old code, use the MFC wizard to generate
>>code,
>>>write my own try other ppl's code etc.) the classview does not show
>>>*ANYTHING*. well in *one* project, it showed the functions and variables
>of
>>>*one* .cpp but does not show the other one's functions/variables, , and
in
>>>another project it worked once and that's it, in other projects it
doesn't
>>>work at all, same thing with the wizardbar, and IntelliSense works
>>>*SOMETIMES*, this is just soooo odd, i tried reinstalling it but still
>>>doesn't work, maybe classview doesn't scan my files???????i am really
>>>frustrated PLEASE HELP!!!!!!!!!!!!!!!!!!



Sun, 27 May 2001 03:00:00 GMT  
 ClassView, Wizardbar and Intellisense do NOT work
I'm having a similar, but smaller problem.  We just upgraded from VC++ 5
to 6, and the Class View for my project looks MOSTLY OK--except the
class I'm doing most of my work in is missing!  And it was there under
VC++ 5.  I've tried all kinds of tricks to get it to show up, but to no
avail.

If you get it figured out, let me know!

Oh--and to the guy who said "Parser should scan the header files," I
agree--should is the operative word.  Doesn't.

Quote:

> ARRRA!!!!!!!!!!!!!!!!!

> i tried everything(loading my old code, use the MFC wizard to generate code,
> write my own try other ppl's code etc.) the classview does not show
> *ANYTHING*. well in *one* project, it showed the functions and variables of
> *one* .cpp but does not show the other one's functions/variables, , and in
> another project it worked once and that's it, in other projects it doesn't
> work at all, same thing with the wizardbar, and IntelliSense works
> *SOMETIMES*, this is just soooo odd, i tried reinstalling it but still
> doesn't work, i am really frustrated PLEASE HELP!!!!!!!!!!!!!!!!!!

> thanks



Mon, 28 May 2001 03:00:00 GMT  
 ClassView, Wizardbar and Intellisense do NOT work
I upgraded from VC5 to VC6 too... see a pattern?

Quote:

>I'm having a similar, but smaller problem.  We just upgraded from VC++ 5
>to 6, and the Class View for my project looks MOSTLY OK--except the
>class I'm doing most of my work in is missing!  And it was there under
>VC++ 5.  I've tried all kinds of tricks to get it to show up, but to no
>avail.

>If you get it figured out, let me know!

>Oh--and to the guy who said "Parser should scan the header files," I
>agree--should is the operative word.  Doesn't.

>> ARRRA!!!!!!!!!!!!!!!!!

>> i tried everything(loading my old code, use the MFC wizard to generate
code,
>> write my own try other ppl's code etc.) the classview does not show
>> *ANYTHING*. well in *one* project, it showed the functions and variables
of
>> *one* .cpp but does not show the other one's functions/variables, , and
in
>> another project it worked once and that's it, in other projects it
doesn't
>> work at all, same thing with the wizardbar, and IntelliSense works
>> *SOMETIMES*, this is just soooo odd, i tried reinstalling it but still
>> doesn't work, i am really frustrated PLEASE HELP!!!!!!!!!!!!!!!!!!

>> thanks



Mon, 28 May 2001 03:00:00 GMT  
 ClassView, Wizardbar and Intellisense do NOT work
try deleting your .ncb file from the project.

Steve


Quote:
>I'm having a similar, but smaller problem.  We just upgraded from VC++ 5
>to 6, and the Class View for my project looks MOSTLY OK--except the
>class I'm doing most of my work in is missing!  And it was there under
>VC++ 5.  I've tried all kinds of tricks to get it to show up, but to no
>avail.

>If you get it figured out, let me know!

>Oh--and to the guy who said "Parser should scan the header files," I
>agree--should is the operative word.  Doesn't.

>> ARRRA!!!!!!!!!!!!!!!!!

>> i tried everything(loading my old code, use the MFC wizard to generate
code,
>> write my own try other ppl's code etc.) the classview does not show
>> *ANYTHING*. well in *one* project, it showed the functions and variables
of
>> *one* .cpp but does not show the other one's functions/variables, , and
in
>> another project it worked once and that's it, in other projects it
doesn't
>> work at all, same thing with the wizardbar, and IntelliSense works
>> *SOMETIMES*, this is just soooo odd, i tried reinstalling it but still
>> doesn't work, i am really frustrated PLEASE HELP!!!!!!!!!!!!!!!!!!

>> thanks



Tue, 29 May 2001 03:00:00 GMT  
 ClassView, Wizardbar and Intellisense do NOT work

Quote:
> try deleting your .ncb file from the project.

Have done.  In fact, I've deleted ALL generated files (via Clean, and
also manually), to no avail.  Also, to the fellow who suggested that I
make sure that my header file is included in the project:  Yes it is (as
opposed to listed in the "External Dependencies" section).

I even tried the following extreme measures:  I removed the files for
the class from my project, then used the Insert New Class feature to
insert a new copy of the class.  This generated dummy .h and .cpp files
(with default constructor and destructor), and listed them in Class
View.  GREAT!  So then I closed Dev Studio, replaced the generated .cpp
and .h files with the real files and reopened.  My class was still in
the Class Viewer--but it still only showed the constructor and
destructor.  I edited the header file to see if that would force a
re-do, and...my class disappeared again!  AAARRRGGGHHH!!!

But I've got a new idea...I'll try generating the files again via New
Class, and this time I'll EDIT them to insert the stuff from my class
into the generated files.  Maybe that'll get it in.  I'll post the
results.

What a pain in the patootie!

Lonnie



Tue, 29 May 2001 03:00:00 GMT  
 ClassView, Wizardbar and Intellisense do NOT work

Quote:
> But I've got a new idea...I'll try generating the files again via New
> Class, and this time I'll EDIT them to insert the stuff from my class
> into the generated files.  Maybe that'll get it in.  I'll post the
> results.

WHOO!  That worked.  Why?  Dunno.  There -is- the generated #if !defined
<very-long-identifier> in the header, vs. my simple #ifndef
_<filename>_H_; maybe that generated name is important somehow.  Also,
and this might be the real reason, I didn't explicitly include the
header for the class in the .cpp file--it was, however, imported via
another header file.  So check that in your case, and if you don't
include the class' header file in the implementation file, add it and
see if that helps.

Good luck--

Lonnie



Tue, 29 May 2001 03:00:00 GMT  
 ClassView, Wizardbar and Intellisense do NOT work
Try to delete to the .ncb file and make sure everything is not read only..
Quote:

>nope


>>    ClassView should scan off header files which are added to the project.

>>--
>>Truth,
>>   James [MVP]
>>http://www.NJTheater.Com       -and-
>>http://www.NJTheater.Com/JamesCurran


>>>>i tried everything(loading my old code, use the MFC wizard to generate
>>>code,
>>>>write my own try other ppl's code etc.) the classview does not show
>>>>*ANYTHING*. well in *one* project, it showed the functions and variables
>>of
>>>>*one* .cpp but does not show the other one's functions/variables, , and
>in
>>>>another project it worked once and that's it, in other projects it
>doesn't
>>>>work at all, same thing with the wizardbar, and IntelliSense works
>>>>*SOMETIMES*, this is just soooo odd, i tried reinstalling it but still
>>>>doesn't work, maybe classview doesn't scan my files???????i am really
>>>>frustrated PLEASE HELP!!!!!!!!!!!!!!!!!!



Tue, 10 Jul 2001 03:00:00 GMT  
 ClassView, Wizardbar and Intellisense do NOT work
doesn't fix it...

Quote:

>Try to delete to the .ncb file and make sure everything is not read only..


>>nope


>>>    ClassView should scan off header files which are added to the
project.

>>>--
>>>Truth,
>>>   James [MVP]
>>>http://www.NJTheater.Com       -and-
>>>http://www.NJTheater.Com/JamesCurran


>>>>>i tried everything(loading my old code, use the MFC wizard to generate
>>>>code,
>>>>>write my own try other ppl's code etc.) the classview does not show
>>>>>*ANYTHING*. well in *one* project, it showed the functions and
variables
>>>of
>>>>>*one* .cpp but does not show the other one's functions/variables, , and
>>in
>>>>>another project it worked once and that's it, in other projects it
>>doesn't
>>>>>work at all, same thing with the wizardbar, and IntelliSense works
>>>>>*SOMETIMES*, this is just soooo odd, i tried reinstalling it but still
>>>>>doesn't work, maybe classview doesn't scan my files???????i am really
>>>>>frustrated PLEASE HELP!!!!!!!!!!!!!!!!!!



Thu, 12 Jul 2001 03:00:00 GMT  
 
 [ 15 post ] 

 Relevant Pages 

1. ClassView, Wizardbar and Intellisense do NOT work

2. ClassView, Wizardbar and Intellisense do NOT work

3. C++/ATL/ADO - Intellisense not working (statement completion options) not working

4. WizardBar does not work properly for my own class

5. classview and wizardbar problems

6. Removing old classes from ClassView and WizardBar

7. IMPORTANT: IntelliSense does not work after __typeof operator

8. Intellisense: Often does not work, reproducable sample

9. IntelliSense Does NOT Work?

10. intellisense not working

11. IntelliSense not working with header file only classes

12. Intellisense does not work any more

 

 
Powered by phpBB® Forum Software