Paste not working when Application_BeforeBuildStart defined 
Author Message
 Paste not working when Application_BeforeBuildStart defined

Hi all,

  Am I crazy, or just insane, but every so often I cannot paste text
into the VC IDE. The following is list of things that makes me think
someone up there must really have it in for me

   * The problem occurs inconsistently, I can’t recreate it, I
just have to get lucky
   * When the problem does happen it only happens if the copy buffer
is within a certain size, i.e. I would be able to copy/paste a block
of text anywhere from 1 to 9 characters in length or a 19+, but not a
length of 10 to 18. These lengths, of course, change every time the
problem occurs.
   * Copy does work, I can copy text and paste it in notepad, only
paste that doesn’t work
   * Sometimes, if I hold down Ctrl+V for about 30seconds, it starts
working again
   * Sometimes, if I load the macro editor, it starts working again
   * I wrote an Application_BeforeBuildStart macro which updates the
version information in a resource so that every time I compile a
project, a new minor version number is given. If I remove this
function, I *don’t* ever have a problem with pasting... but
why?!?

Has anyone ever experienced anything like this?

Is there anything I can do?

BTW, I could never give up my Application_BeforeBuildStart function,
so removing it permanently is not an option.

Thanks for any help
  MRe



Tue, 20 Apr 2004 23:01:02 GMT  
 Paste not working when Application_BeforeBuildStart defined
I think (this is from a while ago) that this is a VC++ 6.0 bug. VC++
6.0 has a heap corruption problem that renders it incompatible with
the (wait for it) default VC++ 6.0 heap.

There's a delicious irony in VC++ 6.0 being incompatible with itself.

I think it only shows up on NT 4.0, but I could be wrong. The hack/fix
was to mark VC++ as being incompatible with the VC++ 6.0 heap so
that it would use the VC++ style heap functions.

This may have been fixed in a service pack - make sure you have the
latest service packs for VC++.

This used to be a FAQ. Search on it to see what you find.

Quote:

> Hi all,

>   Am I crazy, or just insane, but every so often I cannot paste text
> into the VC IDE. The following is list of things that makes me think
> someone up there must really have it in for me

>    * The problem occurs inconsistently, I can’t recreate it, I
> just have to get lucky
>    * When the problem does happen it only happens if the copy buffer
> is within a certain size, i.e. I would be able to copy/paste a block
> of text anywhere from 1 to 9 characters in length or a 19+, but not a
> length of 10 to 18. These lengths, of course, change every time the
> problem occurs.
>    * Copy does work, I can copy text and paste it in notepad, only
> paste that doesn’t work
>    * Sometimes, if I hold down Ctrl+V for about 30seconds, it starts
> working again
>    * Sometimes, if I load the macro editor, it starts working again
>    * I wrote an Application_BeforeBuildStart macro which updates the
> version information in a resource so that every time I compile a
> project, a new minor version number is given. If I remove this
> function, I *don’t* ever have a problem with pasting... but
> why?!?

> Has anyone ever experienced anything like this?

> Is there anything I can do?

> BTW, I could never give up my Application_BeforeBuildStart function,
> so removing it permanently is not an option.

> Thanks for any help
>   MRe



Wed, 21 Apr 2004 11:21:10 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Paste ATL control from IE to Word does not work

2. question: paste does not work in vc editor

3. Copy/Paste using Ctrl+C/Ctrl+V does not work in CHtmlView Class

4. Copy/Paste via keyboard not working in FormView

5. Guard define not working?

6. C #define macros not working with C++

7. C++/ATL/ADO - Intellisense not working (statement completion options) not working

8. Help: cut and paste working infrequently

9. Cut and Paste stops working

10. Paste in VS6 SP1 stops working.

11. VC5 - paste stopped working

12. Pasting into RichTextBox - formatting taxt pasted as text!

 

 
Powered by phpBB® Forum Software