SYSINCL.dat doesn't seem to work in VC7.1 
Author Message
 SYSINCL.dat doesn't seem to work in VC7.1

According to the documentation you can exclude files in a directory from
dependency checking by including that directory in the SYSINCL.dat file.

This does not work for me. I have a number of rarely modified header files
in a special directory and I added that directory to SYSINCL.dat.
I expect changes to any of these header files to NOT cause a rebuild, but
VC7.1 does rebuild dependent files anyway.

Any ideas?
Hermann Hubschle



Wed, 30 Nov 2005 11:15:37 GMT  
 SYSINCL.dat doesn't seem to work in VC7.1

Quote:

>According to the documentation you can exclude files in a directory from
>dependency checking by including that directory in the SYSINCL.dat file.

>This does not work for me. I have a number of rarely modified header files
>in a special directory and I added that directory to SYSINCL.dat.
>I expect changes to any of these header files to NOT cause a rebuild, but
>VC7.1 does rebuild dependent files anyway.

Some things to double-check:

Did you shut down the IDE and restart it after making your additions?

Did you put sysincl.dat in the right directory?

Here are the docs for the feature:

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vcco...

--
Doug Harrison
Microsoft MVP - Visual C++



Wed, 30 Nov 2005 11:23:00 GMT  
 SYSINCL.dat doesn't seem to work in VC7.1
1. I did shout down the IDE.
2. I added the entries to the SYSINCL.dat file in
c:\Documents and Settings\username\Local Settings\Application
Data\Microsoft\VisualStudio\7.1\

The same problem seems to appear on all our systems.



Quote:

> >According to the documentation you can exclude files in a directory from
> >dependency checking by including that directory in the SYSINCL.dat file.

> >This does not work for me. I have a number of rarely modified header
files
> >in a special directory and I added that directory to SYSINCL.dat.
> >I expect changes to any of these header files to NOT cause a rebuild, but
> >VC7.1 does rebuild dependent files anyway.

> Some things to double-check:

> Did you shut down the IDE and restart it after making your additions?

> Did you put sysincl.dat in the right directory?

> Here are the docs for the feature:

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vcco...

- Show quoted text -

Quote:

> --
> Doug Harrison
> Microsoft MVP - Visual C++



Wed, 30 Nov 2005 11:46:18 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Array Casting doesn't seem to work

2. Encoding.GetEncoding(866) doesn't seem to work for Russian text

3. CDatabase doesn't seem to be working in Release builds

4. VC DEBUGGER doesn't seem to work with IE 4.0 on Win95

5. VC DEBUGGER doesn't seem to work with IE 4.0 on Win95

6. PRB: Wildcard Expansion for Console App Doesn't Seem to Work

7. Wildcard Expansion for Console App Doesn't Seem to Work

8. AddDocTemplate doesn't seem to work

9. fseek() doesn't seem to be working

10. SubclassWindow doesn't seem to work?!

11. HELP : LoadBitmap doesn't seem to work

12. GetBoundsRect doesn't seem to work

 

 
Powered by phpBB® Forum Software