Error spawning cl.exe 
Author Message
 Error spawning cl.exe

I installed MSVC++ 5.0 on brand new machine with NT Workstation 4.0 service
pack 3.

When I try to compile small test project, all I'm getting in IDE is:

Compiling...
Error spawning cl.exe

I cannot figure out what might be wrong... I have installed MSVC++ 5.0
before on more machines  and have never seen this problem. My path and whole
environment seems to be OK. Can anybody give me any hint what might be going
wrong ?

Thank you

Lester

Here is Environment:

ComSpec=C:\WINNT\system32\cmd.exe
HOMEDRIVE=C:
HOMEPATH=\
include=c:\program files\devstudio\vc\include;c:\program
files\devstudio\vc\atl\include;c:\program
files\devstudio\vc\mfc\include;c:\program files\od20\Include
lib=c:\program files\devstudio\vc\lib;c:\program
files\devstudio\vc\mfc\lib;c:\program files\od20\Lib
MSDevDir=C:\Program Files\DevStudio\SharedIDE
OS=Windows_NT
Os2LibPath=C:\WINNT\system32\os2\dll;
Path=C:\WINNT\system32;C:\WINNT;c:\program
files\devstudio\sharedide\bin\ide;c:\program
files\devstudio\sharedide\bin;C:\Program
Files\DevStudio\VC\BIN\WINNT;c:\program
files\devstudio\vc\bin;c:\batch;c:\program files\od20\Lib
PATHEXT=.COM;.EXE;.BAT;.CMD
PROCESSOR_ARCHITECTURE=x86
PROCESSOR_IDENTIFIER=x86 Family 6 Model 5 Stepping 0, GenuineIntel
PROCESSOR_LEVEL=6
PROCESSOR_REVISION=0500
PROMPT=$P$G
SystemDrive=C:
SystemRoot=C:\WINNT
TEMP=C:\TEMP
TMP=C:\TEMP
USERNAME=Administrator
USERPROFILE=C:\WINNT\Profiles\Administrator
windir=C:\WINNT



Thu, 05 Oct 2000 03:00:00 GMT  
 Error spawning cl.exe

the devstudio ide doesn't use that environment. See setting under
Tools|Options|Directories|ExecutableFiles

steve


Quote:
>I installed MSVC++ 5.0 on brand new machine with NT Workstation 4.0 service
>pack 3.

>When I try to compile small test project, all I'm getting in IDE is:

>Compiling...
>Error spawning cl.exe

>I cannot figure out what might be wrong... I have installed MSVC++ 5.0
>before on more machines  and have never seen this problem. My path and
whole
>environment seems to be OK. Can anybody give me any hint what might be
going
>wrong ?

>Thank you

>Lester

>Here is Environment:

>ComSpec=C:\WINNT\system32\cmd.exe
> ...



Fri, 06 Oct 2000 03:00:00 GMT  
 Error spawning cl.exe

Quote:

>I installed MSVC++ 5.0 on brand new machine with NT Workstation 4.0 service
>pack 3.

>When I try to compile small test project, all I'm getting in IDE is:

>Compiling...
>Error spawning cl.exe

>I cannot figure out what might be wrong... I have installed MSVC++ 5.0
>before on more machines  and have never seen this problem. My path and whole
>environment seems to be OK. Can anybody give me any hint what might be going
>wrong ?

>Thank you

>Lester

>Here is Environment:

<snip>

I had this problem on my dual-boot machine.

After installing and running VC5 I could compile and link a project.
Later, I shut down VC and my machine and after the re-boot, VC would
throw out the "error spawning cl.exe" ?!?!?!?!?!?

After a few hours looking for the solution, I noticed that the
"executable files" directory in the options included ALL of my path.
It had used the path found in the autoexec.bat file (which gets called
when I boot win95) and added each directory to the list in VC.  I
renamed autoexec.bat and re-booted my machine.... hey presto.... it
works and linked first time.

This happened with VC5 SP3 so I think it may be more of an OS problem
than a VC prob.

Ta ra,

--
Jim



Sat, 14 Oct 2000 03:00:00 GMT  
 Error spawning cl.exe

Quote:

>the devstudio ide doesn't use that environment.

Sorry, but it does. (found this out after hours of wondering why I
couldn't compile)

See ya,

--
Jim



Sat, 14 Oct 2000 03:00:00 GMT  
 Error spawning cl.exe

Hello,

I've got a small problem:

Running VC++ 5.0 under NT 4.0 w/ service patch 3 + hotfix for TrueColor
Java in IE). I recently installed VC++ 5.0 onto this machine (had to get
the service patch + hotfix to get the newest version of IE to be able to
read the help). Now, when I try to compile any of my projects (which are
compiling fine on other machines), I see:

--------------------Configuration: VolumeView - Win32
Debug--------------------
Compiling...
Error spawning cl.exe

VolumeView.exe - 1 error(s), 0 warning(s)

However, if I log in as Administrator, the compile works fine. The
reason I suspect that
something strange is going on is that on another machine, almost
identically configured, someone else in the lab is having VC++ problems
(unable to access a bunch of MSDN files), which are aleviated by logging
in as Administrator, as well.

Has anyone seen any similar problems? I did a fruitless search on the MS
knowledge base. Any thoughts on what this might be/ possible solutions?

Thanks,
Andrew Bzostek


Computer Integrated Surgery Lab
Department of Computer Science
The Johns Hopkins University



Sat, 21 Oct 2000 03:00:00 GMT  
 Error spawning cl.exe

Sounds like the paths are not setup properly.  One thought: When VC++ is
installed on NT it has to be installed by a person with Administrator
rights, otherwise the registry settings will not be stored properly.

--
Is there another word for synonym?

 ---------------------------------------------------------------------------
---
| Author for Pinnacle Publishing "Visual C++ Developer"
http://www.pinpub.com/ |
| http://lucifer.lotus.com/jim/main.htm
|
 ---------------------------------------------------------------------------
---



Sat, 21 Oct 2000 03:00:00 GMT  
 
 [ 6 post ] 

 Relevant Pages 

1. Compile error: Error Spawning Cl.exe or link.exe

2. error spawning cl.exe when profile

3. error spawning cl.exe in v6

4. Error: spawning cl.exe

5. Error spawning cl.exe???

6. What causes "Error spawning cl.exe"

7. error spawning cl.exe

8. VC5.0: Error Spawning CL.EXE

9. Error spawning cl.exe???

10. error spawning cl.exe

11. Error spawning cl.exe

12. "error spawning cl.exe"

 

 
Powered by phpBB® Forum Software