Script being called but not executed??? 
Author Message
 Script being called but not executed???

If I call a function across a frame using
parent.frames(0).document.script.vbIncreaseItem('itemcode') from frame #2
(out of 3; 1 {actually 0 in the script} has the code in it), it doesn't do
anything at all (acts as if I turned scripting off on the frame).  But,
the strange thing is, if there is an error in the coding, it still reports
the error, line number, char number and prompts me to turn off scripts
when I try to execute the function.

I've searched and searched on the internet, and there is not one word
(even in MicroSoft's VBScript/IE4.0 Obj Model documents) about cross-frame
scripting, so if anyone can point me in some direction I'd be glad... I'm
not having much luck figuring it out trial and error style.

Thanks a ton!
  Joe Duffy



Sat, 21 Oct 2000 03:00:00 GMT  
 Script being called but not executed???

This is how I use cross-frame scripting:

parent.frame_name.function_name();

Neil Henderson
--

Quote:

>If I call a function across a frame using
>parent.frames(0).document.script.vbIncreaseItem('itemcode') from frame #2
>(out of 3; 1 {actually 0 in the script} has the code in it), it doesn't do
>anything at all (acts as if I turned scripting off on the frame).  But,
>the strange thing is, if there is an error in the coding, it still reports
>the error, line number, char number and prompts me to turn off scripts
>when I try to execute the function.

>I've searched and searched on the internet, and there is not one word
>(even in MicroSoft's VBScript/IE4.0 Obj Model documents) about cross-frame
>scripting, so if anyone can point me in some direction I'd be glad... I'm
>not having much luck figuring it out trial and error style.

>Thanks a ton!
>  Joe Duffy




Sun, 22 Oct 2000 03:00:00 GMT  
 Script being called but not executed???

Joe, if you are still having trouble, try sending in the code you are
using...
I have an example of accessing functions and activex controls between frames
if you want to see if you can find where you are having trouble:
http://www.public.se/heidi/frames

-Heidi

Quote:
>This is how I use cross-frame scripting:

>parent.frame_name.function_name();

>Neil Henderson
>--


>>If I call a function across a frame using
>>parent.frames(0).document.script.vbIncreaseItem('itemcode') from frame #2
>>(out of 3; 1 {actually 0 in the script} has the code in it), it doesn't do
>>anything at all (acts as if I turned scripting off on the frame).  But,
>>the strange thing is, if there is an error in the coding, it still reports
>>the error, line number, char number and prompts me to turn off scripts
>>when I try to execute the function.



Sun, 22 Oct 2000 03:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Script being called but not executed???

2. Help: csp-scripts are not executed but displayed as text

3. I am trying to update a record, i am not using data control

4. I am trying to update a record, i am not using data control

5. I am having trouble executing a .exe file on the server

6. Execute scripts on server,not on the client side

7. Scripts Not Executing...

8. execute script from a PC not in domain

9. Execute scripts on server,not on the client side

10. Script not executed because CPU load nearly 100%

11. Not very important, but I am curious

12. Not running, am I doing something wrong

 

 
Powered by phpBB® Forum Software