how to load coleague's PDB into my machine? 
Author Message
 how to load coleague's PDB into my machine?

Just put the .pdb file in the same directory as the .dll. The de{*filter*}
always looks there.

Quote:

> Using Win2k (SP1), VC++ 6.0 (SP4)
> My coleague builds his DLL on his machine. This DLL holds full path to PDB.
> On my machine I want to use his DLL with its PDB, but everytime I set it up
> in Project Settings->Debug->Additional DLLs I got two messages in output
> window when starting debugged process, one says symbols were succesfully
> loaded and the next one that this DLL does not hold debugging information. I
> place corresponding PDB into \Winnt\Symbols\dll folder, since I read this is
> default path for de{*filter*} (John Robbins - Debugging Applications) and I
> cannot reproduce his developing environment on my machine (he uses different
> directory structures, different disk names etc.). Nevertheless I never get
> symbols into my debuger to load. I have checked his PDB, it is set as
> Program Database, with type information in (separate types unchecked). He
> has no problem to use his DLL & PDB in his de{*filter*}.

> What could be the problem?

> --
> Richard Musil

--
.Bruce Dawson, Humongous Entertainment (we're hiring).
http://www.*-*-*.com/
Send job applications by e-mail, post technical questions
to the newsgroups please. Thanks.


Tue, 22 Apr 2003 03:00:00 GMT  
 how to load coleague's PDB into my machine?
Using Win2k (SP1), VC++ 6.0 (SP4)
My coleague builds his DLL on his machine. This DLL holds full path to PDB.
On my machine I want to use his DLL with its PDB, but everytime I set it up
in Project Settings->Debug->Additional DLLs I got two messages in output
window when starting debugged process, one says symbols were succesfully
loaded and the next one that this DLL does not hold debugging information. I
place corresponding PDB into \Winnt\Symbols\dll folder, since I read this is
default path for de{*filter*} (John Robbins - Debugging Applications) and I
cannot reproduce his developing environment on my machine (he uses different
directory structures, different disk names etc.). Nevertheless I never get
symbols into my debuger to load. I have checked his PDB, it is set as
Program Database, with type information in (separate types unchecked). He
has no problem to use his DLL & PDB in his de{*filter*}.

What could be the problem?

--
Richard Musil



Tue, 22 Apr 2003 23:16:38 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Bitmaps don't load on some machines

2. Bitmaps don't load on some machines

3. Loading PDB file slow down suddenly

4. .PDB vs .DBG - Discussion of the Pro's and Con's

5. using FAULT address of EXE sans .pdb in EXE with .pdb

6. PDB API / COFF and PDB file formats

7. C function to get the machine load average

8. .PDB doesn't help!! VC++ debugger

9. what's the trick of pdb file

10. PDB file > 65MB doesn't link

11. release exe's get bigger when specifying pdb symbols

12. Question: Debugger Can't find vc50.pdb

 

 
Powered by phpBB® Forum Software