Problem using fstream in a library... 
Author Message
 Problem using fstream in a library...

This is a very strange error and I'm not sure if I'll be
able to explain it well or if anyone has ever seen this
before.  Basically, I have two projects in a solution, one
which builds to a library and one which builds to an exe.  
The exe uses classes in the library.  All the code works
fine except for when I attempt to use an fstream within
the library.  It breaks when creating or deleting the
fstream object.  I can use fstream just fine in the exe
project, but once it calls a function or class that is
within the library that uses fstream (with nothing
happening inbetween) it will break.  The problem seems
similar to a memory leak, but I know it can't be since
nothing goes on before.
I know this is very strange and probably no one will have
any idea what I'm talking about.  I think I'll just use
something other than fstream to read files.

-Javier



Wed, 09 Mar 2005 08:17:13 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Fstream Problems using VC++ 4

2. fstream C++ library question

3. incompatibility between namespace std and fstream library

4. fstream - Standard C++ Library

5. bug in fstream? (works with fstream.h)

6. fstream ./. fstream.h

7. Using file streams (fstream) with unicode

8. hot to using fstream to get filesize?

9. How to get file status by using methods of fstream

10. Writing to the A drive using fstream

11. Getting last line of a file using fstream

12. Using CArchive handle for std::fstream

 

 
Powered by phpBB® Forum Software