Visual Studio 6.0 hang while debugging 
Author Message
 Visual Studio 6.0 hang while debugging

I was wondering if anyone else has seen this and knows what I can do to
find the problem.

I am using VC++ 6.0 sp5 on WinXP sp1 w/ all current updates.  While while
debugging, the darn thing hangs as if there is a thread not relinquishing
the CPU or somethings is flooding the event system so that normal events
can't get processed.  It never happens in the same spot or seems to relate
to anything I may be doing.  Sometimes I may be stepping over a variable
initialization (int, char *, etc.) statement, sometimes stepping out of a
function, sometimes stepping into a function, sometimes stepping over a
function and sometimes, just pressing "GO" (F5).  

The Window events are processed so slowly I can never get control back to
MSDev, change window focus, etc. unless I kill the MSDEV process.  I used
to have to log out or reboot in order to get the process killed because any
attempts to load the Task Manager or anything else that requires GUI events
to be processed is impossible.  I finally found out that I can call "tskill
msdev" from a command prompt and save myself the trouble of logging out
every time.  I can generally keep a command window open just for that
purpose and get to it with minimal delays.

I am hoping someone can give me some pointers as to how to track down the
problem.  Is there some utility (preferrably command-line ) to show me what
processes or threads may be hogging the CPU or event system?  I am very
frustrated and would greatly appreciate any insight.

Thanks,

Jeff



Mon, 17 Oct 2005 05:53:03 GMT  
 Visual Studio 6.0 hang while debugging
Did you try using taskman (taskmanager) ?

Do you have any third party apps that globally hook window messages
(virutal desktops et all)?

--------------------

Quote:


>Date: Wed, 30 Apr 2003 21:53:03 GMT
>Lines: 29
>Newsgroups: microsoft.public.vc.de{*filter*}
>Subject: Visual Studio 6.0 hang while debugging

>User-Agent: Xnews/06.01.08b
>Path:

cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.sul.t-online.de!t-onlin
e.de!news-spur1.maxwell.syr.edu!news.maxwell.syr.edu!newsfeed-east.nntpserve
r.com!nntpserver.com!TeraNews!not-for-mail
Quote:
>Xref: cpmsftngxa06.phx.gbl microsoft.public.vc.de{*filter*}:15573
>X-Tomcat-NG: microsoft.public.vc.de{*filter*}

>I was wondering if anyone else has seen this and knows what I can do to
>find the problem.

>I am using VC++ 6.0 sp5 on WinXP sp1 w/ all current updates.  While while
>debugging, the darn thing hangs as if there is a thread not relinquishing
>the CPU or somethings is flooding the event system so that normal events
>can't get processed.  It never happens in the same spot or seems to relate
>to anything I may be doing.  Sometimes I may be stepping over a variable
>initialization (int, char *, etc.) statement, sometimes stepping out of a
>function, sometimes stepping into a function, sometimes stepping over a
>function and sometimes, just pressing "GO" (F5).  

>The Window events are processed so slowly I can never get control back to
>MSDev, change window focus, etc. unless I kill the MSDEV process.  I used
>to have to log out or reboot in order to get the process killed because
any
>attempts to load the Task Manager or anything else that requires GUI
events
>to be processed is impossible.  I finally found out that I can call
"tskill
>msdev" from a command prompt and save myself the trouble of logging out
>every time.  I can generally keep a command window open just for that
>purpose and get to it with minimal delays.

>I am hoping someone can give me some pointers as to how to track down the
>problem.  Is there some utility (preferrably command-line ) to show me
what
>processes or threads may be hogging the CPU or event system?  I am very
>frustrated and would greatly appreciate any insight.

>Thanks,

>Jeff



Tue, 18 Oct 2005 05:07:02 GMT  
 Visual Studio 6.0 hang while debugging
I haven't been able to get TaskMan to start after the hang.  I was going
to use it to kill the process.  However, I don't know how it would help
me determine what the problem is since I am sure it is either the
de{*filter*} itself or something within my app.  I do NOT have any global
windows message hooks.

Another note is that it had not done this until about 9 to 12 months
ago.  I suspect that a newer version of a library we use is the problem.
 This library starts some background threads for it's own use, which it
has done for many years.  However I can't be sure when I actually
started having problems and I'm not sure how to tell FOR SURE that this
particular library is the problem, since I am basically dead in the
water onces it hangs.

Is it possible to use MSDev to debug another MSDev process and if so, is
there some way to tell what thread is using all the CPU or where the
events are coming from, etc.?



Quote:
> Did you try using taskman (taskmanager) ?

> Do you have any third party apps that globally hook window messages
> (virutal desktops et all)?



Tue, 18 Oct 2005 06:25:52 GMT  
 Visual Studio 6.0 hang while debugging
Here are some ideas

1. Run taskmanager before you repro this issue - have its performance
graphs up
2. Run your scenario
3. You'll probably notice that the CPU is pegged.( most likley its in an
infinite allocation of memory/resources)

4. From the process list - lower the prority of the offending process to Low
5. Go from here (start by debugging the app)

--------------------

Quote:


>Date: Thu, 01 May 2003 22:25:52 GMT
>Lines: 26
>Newsgroups: microsoft.public.vc.de{*filter*}
>Subject: RE: Visual Studio 6.0 hang while debugging




Quote:
>User-Agent: Xnews/06.01.08b
>Path:

cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.sul.t-online.de!t-onlin
e.de!news-spur1.maxwell.syr.edu!news.maxwell.syr.edu!newsfeed-east.nntpserve
r.com!nntpserver.com!TeraNews!not-for-mail
Quote:
>Xref: cpmsftngxa06.phx.gbl microsoft.public.vc.de{*filter*}:15580
>X-Tomcat-NG: microsoft.public.vc.de{*filter*}

>I haven't been able to get TaskMan to start after the hang.  I was going
>to use it to kill the process.  However, I don't know how it would help
>me determine what the problem is since I am sure it is either the
>de{*filter*} itself or something within my app.  I do NOT have any global
>windows message hooks.

>Another note is that it had not done this until about 9 to 12 months
>ago.  I suspect that a newer version of a library we use is the problem.
> This library starts some background threads for it's own use, which it
>has done for many years.  However I can't be sure when I actually
>started having problems and I'm not sure how to tell FOR SURE that this
>particular library is the problem, since I am basically dead in the
>water onces it hangs.

>Is it possible to use MSDev to debug another MSDev process and if so, is
>there some way to tell what thread is using all the CPU or where the
>events are coming from, etc.?



>> Did you try using taskman (taskmanager) ?

>> Do you have any third party apps that globally hook window messages
>> (virutal desktops et all)?



Thu, 20 Oct 2005 02:32:25 GMT  
 
 [ 4 post ] 

 Relevant Pages 

1. e: *HELP* After install Visual studio .Net, the Visual Studio Enterprise 6.0 stops working

2. *HELP* After install Visual studio .Net, the Visual Studio Enterprise 6.0 stops working

3. *HELP* After install Visual studio .Net, the Visual Studio Enterprise 6.0 stops working

4. Problem with Visual Studio 6.0 (Visual C++ 6.0) !!!!

5. Debugging with Visual Studio 6.0 on Windows XP

6. Can't run debug version after came back from Visual Studio 6.0

7. Debug-Windows in Visual Studio 6.0 (C++) doesn't show CString-Values

8. Linker problem between Dev studio 5.0 and Visual Studio 6.0 VC++

9. porting visual c++ 6.0 addins to visual studio.net

10. Microsoft Visual Studio.NET V.S. Microsoft Visual C++ 6.0

11. Visual Studio 6.0, Visual SDK and ImageMagick

12. Visual Studio desktop layout (Visual Studio/Visual C++ 6)

 

 
Powered by phpBB® Forum Software