problem by open recordset 
Author Message
 problem by open recordset

hello,

i tried to open CRecordset ( i.e.special table) by doing that :

in *.h

CDatabase m_database;
CRecordset m_recordset;

in *cpp.

m_database.Open(_T("Microsoft Access-Datenbank"), FALSE,FALSE,
_T("ODBC;UID=") + sUser);

// that has worked
// it is a german driver

// now i have choosen my databse by using a dialog the MFC has shown me

m_recordset.m_pDatabase = &m_database;
m_recordset.Open(CRecordset::snapshot, _T("myTable"));

// here i got an assertion.

could anybody tell me please what is the reason for it

thnak you
greetings



Tue, 22 Jul 2003 19:49:55 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Access violation in Recordset.Open() and Recordset.RecordCount

2. problems Opening 500 000 + recordset

3. problem in using Recordset to open ORACLE database via ODBC system data source

4. Problem with ADO recordsets of recordsets under MTS

5. Exception thrown when opening ADO recordset

6. Status Codde = 207 error message when Recordset::Open fails

7. Opening a DAO RecordSet to a Linked Table

8. Open Emtpy ADO Recordset

9. The recordset can't open

10. Can't open Recordset

11. How do open Recordset from XML stream object use ADO in VC6

12. How must I open Recordset, without deleting records?

 

 
Powered by phpBB® Forum Software