Insert and update problem after changing db 
Author Message
 Insert and update problem after changing db

I am using NT 4.0, OLE DB 1.1, Visual C++ 6.0 using the ATL database
consumer wizard, and Access 97. I have written a program that reads a
data source and creates new rows in an Access database. It worked fine
until I modified the database by adding a new column.

Once I had modified the database, I could MoveFirst(), MoveLast(),
MoveNext(), MovePrev(), and Delete(). However, Insert() and SetData()
now fail. I tried deleting the ODBC entry for the database and creating
a new entry before (and after) running the ATL db wizard on the new mdb
file; renaming the ODBC control panel entry; importing the entire
database into a new database, deleting the old from the ODBC registry,
and entering the new database, all to no avail.

This cannot be an unusual situation. Has anyone else encountered it? If
so, how did you get around the problem? Any help will be much
appreciated.

--Tom Clune, MediSpectra, Inc.

Sent via Deja.com http://www.*-*-*.com/
Share what you know. Learn what you don't.



Sat, 24 Nov 2001 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. OLE DB From VC++ 6.0 Delayed Update Problem on Insert

2. Insert, Update, Delete of rows using OLE DB ATL Consumer Templates

3. Update (OLEDB) not writing changes in DB

4. Problem inserting binray field from VC++6.0 using ADO to SQL7,0 DB

5. ADO.NET problem Updating Access-DB

6. OLE DB adding and changing a rowset problem

7. user change or change user rights for MS ACCESS DB with DAO (MFC)

8. How much code change when changing DB types?

9. Change Display Settings- update problem?

10. Change Display Settings- update problem?

11. Inserting data into a MySQL DB via the C API

12. insert : Multiple-step OLE DB operation generated errors

 

 
Powered by phpBB® Forum Software