Using CDaoDatabase/CDaoRecordset from inside an ATL/MFC COM Component 
Author Message
 Using CDaoDatabase/CDaoRecordset from inside an ATL/MFC COM Component

I'm trying to use CDaoDatabase/CDaoRecordset objects from inside an
ATL/MFC COM Component.

I've been having a lot of trouble getting the DAO Engine initialized
on component creation and shutdown on component destruction.

Where is the proper place to stick AfxDaoInit and AfxDaoTerm?

I've tried putting them in InitInstance/ExitInstance of the DLL's
CWinApp object...

        ... That causes odd memory leaks...

I've tried putting them in the component's initialization and cleanup
methods...

        ... That causes assertion failures or exceptions

Any Ideas?

Mark Lehmoine



Sat, 14 Apr 2001 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Problem using activex control inside ATL com dll

2. MFC Framework prblem inside ATL COM project

3. Using CDaoRecordset / CDaoDatabase

4. creating com+ component using atl smartptr

5. CDaoDatabase in COM Component Problem

6. Problems using an MFC/ATL Multithreaded COM Obj with an MFC app

7. Using COM component in non MFC program.

8. ATL COM - Passing ATL COM classes through another ATL COM class in the same app

9. Problem with scripting context when using VB com object inside VC com object

10. Is there any way to achieve multithreading inside MTS COM components

11. COM client (MFC) using ATL to sink events ?

12. Using MFC to build a COM dll rather than ATL

 

 
Powered by phpBB® Forum Software