event_receiver and event_source in same class fails to compile 
Author Message
 event_receiver and event_source in same class fails to compile

I lost the connection while attempting to post this the
first time so I'll try again.  Hopefully this isn't a
duplicate.

I am unable to get the event_receiver(com) and event_source
(com) attributes to compile if they are used in the same
class.  When parsing the _hook statement, the compiler
fails to find the event handler method in the class.  
Commenting out the event_source attribute causes
compilation to succeed.  Is this a known issue/limitation?

I could break the class into subclasses but it seems like
a lot of work just to send and receive events.  I
currently use the pre-7.0 mechanism using manual event
handling but I don't like it.

Any help is greatly appreciated, thanks.

Michael Taylor, MCP - 4/4/02
DCS Corp.



Mon, 20 Sep 2004 21:53:03 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. event_receiver and event_source in same class fails

2. event_source and event_receiver in coclass

3. ATL7 event_source and event_receiver at the same time

4. event_source and event_receiver attributes

5. Compiler error when using event_source(native) and event_receiver(native)...

6. keyword "event_source" must in conjunction with "event_receiver"?

7. event_source(native) not injecting event initialization code into constructor always

8. compiling an AddIn project fails

9. event_source, and event_receive problems...

10. event_source attribute injected code does not work in thread

11. Dynamic Method call ( Invoke method ) failing in service when compiled as ReleaseMinDependancy

12. ATL macro failing to compile

 

 
Powered by phpBB® Forum Software