FinalRelease not called on my ATL generated object ! 
Author Message
 FinalRelease not called on my ATL generated object !

Hi I'm developing on WinXP and VS C++ 6.0 and FinalRelease are not called,
but if I try the code on machine with Win2000 it is called.

Any solutionis ?



Sat, 26 Feb 2005 00:49:34 GMT  
 FinalRelease not called on my ATL generated object !
You have given very little information, and it is hard to even guess what's
wrong. But this is typical if your reference counting is incorrect.

Did you copy the compiled code from W2K to WXP and run it? What happens?

Have to tried to use _ATL_DEBUG_INTERFACES to trace the reference count?


Quote:
> Hi I'm developing on WinXP and VS C++ 6.0 and FinalRelease are not called,
> but if I try the code on machine with Win2000 it is called.

> Any solutionis ?



Sat, 26 Feb 2005 02:27:25 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Why is FinalRelease not called on my ATL generated object?

2. FinalRelease not being called when object is pooled.

3. Ref count goes to zero, FinalRelease not called

4. FinalRelease() not called in control

5. FinalRelease() not called in COM+ application

6. NEWBIE calling ATL gods: Problem in calling DOM object

7. Simple ATL Object-Returning a value to the calling object

8. Error in classes generated with ATL Object Wizard

9. Error generating New ATL Object

10. Merge Proxy/stub (in ATL) generated DLL does not change the Proxystubclsid32

11. ATL WinXP and CComObjectRootEx::FinalRelease()

12. ATL Sucks, FinalRelease Problem

 

 
Powered by phpBB® Forum Software