Doubt While using Simple Object 
Author Message
 Doubt While using Simple Object

Hello

I have Created an ATL Simple Object . Can i Make it run perfectly on  MTS or
i have to use "MS Transaction Server Component"  only .

I have been facing problem of this type while accessing methods
and properties with "Simple Object" When Running on MTS.

Problem 1.
''''''''''''''''''''''''''''''''''''
Debug Error!

Program:C:\WINNT\saytem32\dllhost.exe
Module:
File:i386\chkesp.c
Line:42

The Values of ESP was not properly saved across a Function call. This is
usually a result
of calling a function declared with one calling convention with a function
pointer declared
with a different calling convention.
'''''''''''''''''''''''''''

after few seconds this error is seen.

Problem 2:
''''''''''''''''''''''
Run-time error '-2147023170(800706be)':

Automation error
The remote procedure call failed.
''''''''''''''''''''''''

Is it Possible to make the "ATL Simple Objects" to run the Same way as "MS
Transaction Server Component" runs on the MTS . If Yes wht all changes i
have to make in the "Simple Object".

Thanks 4 ur Help .



Mon, 30 May 2005 19:49:43 GMT  
 Doubt While using Simple Object
did you register proxy?
Quote:
>-----Original Message-----
>Hello

>I have Created an ATL Simple Object . Can i Make it run

perfectly on  MTS or
Quote:
>i have to use "MS Transaction Server Component"  only .

>I have been facing problem of this type while accessing
methods
>and properties with "Simple Object" When Running on MTS.

>Problem 1.
>''''''''''''''''''''''''''''''''''''
>Debug Error!

>Program:C:\WINNT\saytem32\dllhost.exe
>Module:
>File:i386\chkesp.c
>Line:42

>The Values of ESP was not properly saved across a

Function call. This is
Quote:
>usually a result
>of calling a function declared with one calling

convention with a function

- Show quoted text -

Quote:
>pointer declared
>with a different calling convention.
>'''''''''''''''''''''''''''

>after few seconds this error is seen.

>Problem 2:
>''''''''''''''''''''''
>Run-time error '-2147023170(800706be)':

>Automation error
>The remote procedure call failed.
>''''''''''''''''''''''''

>Is it Possible to make the "ATL Simple Objects" to run
the Same way as "MS
>Transaction Server Component" runs on the MTS . If Yes
wht all changes i
>have to make in the "Simple Object".

>Thanks 4 ur Help .

>.



Mon, 30 May 2005 21:34:44 GMT  
 Doubt While using Simple Object

Thanks

I did the following changes in my Atl Application
"
use the  -Oicf and /MD compiler options; and link the DLL with the
mtxih.lib, LE32.lib, and ADVAPI32.lib libraries provided by MTS. The
mtxih.lib library must be the first file that you link into your proxy-stub
DLL.
"

 n then built it . Then registered it on MTS But i still coudn't get rid of
that problem . I'm using "Simple Object " can this b the reason . Should i b
using "MTS Component" .

Thanks for ur Help.


Quote:
> Hello

> I have Created an ATL Simple Object . Can i Make it run perfectly on  MTS
or
> i have to use "MS Transaction Server Component"  only .

> I have been facing problem of this type while accessing methods
> and properties with "Simple Object" When Running on MTS.

> Problem 1.
> ''''''''''''''''''''''''''''''''''''
> Debug Error!

> Program:C:\WINNT\saytem32\dllhost.exe
> Module:
> File:i386\chkesp.c
> Line:42

> The Values of ESP was not properly saved across a Function call. This is
> usually a result
> of calling a function declared with one calling convention with a function
> pointer declared
> with a different calling convention.
> '''''''''''''''''''''''''''

> after few seconds this error is seen.

> Problem 2:
> ''''''''''''''''''''''
> Run-time error '-2147023170(800706be)':

> Automation error
> The remote procedure call failed.
> ''''''''''''''''''''''''

> Is it Possible to make the "ATL Simple Objects" to run the Same way as "MS
> Transaction Server Component" runs on the MTS . If Yes wht all changes i
> have to make in the "Simple Object".

> Thanks 4 ur Help .



Mon, 30 May 2005 21:56:59 GMT  
 Doubt While using Simple Object

Thanks

I did the following changes in my Atl Application
"
use the  -Oicf and /MD compiler options; and link the DLL with the
mtxih.lib, LE32.lib, and ADVAPI32.lib libraries provided by MTS. The
mtxih.lib library must be the first file that you link into your proxy-stub
DLL.
"

 n then built it . Then registered it on MTS But i still coudn't get rid of
that problem . I'm using "Simple Object " can this b the reason . Should i b
using "MTS Component" .

Thanks for ur Help.


Quote:
> Hello

> I have Created an ATL Simple Object . Can i Make it run perfectly on  MTS
or
> i have to use "MS Transaction Server Component"  only .

> I have been facing problem of this type while accessing methods
> and properties with "Simple Object" When Running on MTS.

> Problem 1.
> ''''''''''''''''''''''''''''''''''''
> Debug Error!

> Program:C:\WINNT\saytem32\dllhost.exe
> Module:
> File:i386\chkesp.c
> Line:42

> The Values of ESP was not properly saved across a Function call. This is
> usually a result
> of calling a function declared with one calling convention with a function
> pointer declared
> with a different calling convention.
> '''''''''''''''''''''''''''

> after few seconds this error is seen.

> Problem 2:
> ''''''''''''''''''''''
> Run-time error '-2147023170(800706be)':

> Automation error
> The remote procedure call failed.
> ''''''''''''''''''''''''

> Is it Possible to make the "ATL Simple Objects" to run the Same way as "MS
> Transaction Server Component" runs on the MTS . If Yes wht all changes i
> have to make in the "Simple Object".

> Thanks 4 ur Help .



Thu, 02 Jun 2005 21:33:16 GMT  
 Doubt While using Simple Object

Thanks

I did the following changes in my Atl Application
"
use the  -Oicf and /MD compiler options; and link the DLL with the
mtxih.lib, LE32.lib, and ADVAPI32.lib libraries provided by MTS. The
mtxih.lib library must be the first file that you link into your proxy-stub
DLL.
"

 n then built it . Then registered it on MTS But i still coudn't get rid of
that problem . I'm using "Simple Object " can this b the reason . Should i b
using "MTS Component" .

Thanks for ur Help.


Quote:
> Hello

> I have Created an ATL Simple Object . Can i Make it run perfectly on  MTS
or
> i have to use "MS Transaction Server Component"  only .

> I have been facing problem of this type while accessing methods
> and properties with "Simple Object" When Running on MTS.

> Problem 1.
> ''''''''''''''''''''''''''''''''''''
> Debug Error!

> Program:C:\WINNT\saytem32\dllhost.exe
> Module:
> File:i386\chkesp.c
> Line:42

> The Values of ESP was not properly saved across a Function call. This is
> usually a result
> of calling a function declared with one calling convention with a function
> pointer declared
> with a different calling convention.
> '''''''''''''''''''''''''''

> after few seconds this error is seen.

> Problem 2:
> ''''''''''''''''''''''
> Run-time error '-2147023170(800706be)':

> Automation error
> The remote procedure call failed.
> ''''''''''''''''''''''''

> Is it Possible to make the "ATL Simple Objects" to run the Same way as "MS
> Transaction Server Component" runs on the MTS . If Yes wht all changes i
> have to make in the "Simple Object".

> Thanks 4 ur Help .



Sat, 04 Jun 2005 16:58:54 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. Doubt using Simple Object

2. microsoft visual studio - simple doubt

3. simple doubt-dll

4. Simple doubt-Dll

5. Can u help me?I've a simple doubt in accessing data from VC++

6. simple C++ string doubt

7. Simple Doubt on Mouse Event Capture

8. Some simple STL doubts.

9. Simple ATL Com object problem on simplest examples

10. doubt regarding the destruction of objects we create

11. Doubt in WinApp Application Object

12. Returns a ATL Simple object by a method of another ATLSimple object

 

 
Powered by phpBB® Forum Software