addresssOf Again!!..Pls Help!! 
Author Message
 addresssOf Again!!..Pls Help!!

Hello!

this is a very typicall problem, regarding "AddressOf" Operator

What i am doing is, having an ActiveX DLL which gives me Video Frame passed
by the VFW, using the Address of a procedure in a Public Module.

i've sorted out the re-enterency by the hack provided in VBAccelerator. so i
can identify every object of the in-Process server.and call each object's
Method to pass the frame up the tree.

now i turned the ActiveX DLL into ActiveX Exe. When in the Design mode,
running the EXE in VB IDE, it smoothly passes out the frames and i can view
them simultaniously. but when i compile it and run it as an EXE, outside the
VB IDE, it gets connected to the given Video Capture drivers and i also
start to get the frames in different picture boxes. but the capture driver
to which i connect earlier, stops responding, i mean and the second one
shows frames smoothly.
when i disconnect the second one.. the first one gets smooth again.

what am i doing wrong here??

pls help!!

thanks in Advance
Raju



Wed, 09 Feb 2005 13:17:05 GMT  
 addresssOf Again!!..Pls Help!!
no expert, but have a look at the threading rules for the varios
species of DLL's and EXE's...  You may be creating a blocking
thread thats not playing nice with other consumers of the data
stream...  I know the IDE alters the behavior or your program so
you should place no trust in the results from there where threading
is concerned.

I am probably way off, but...

also, have a look at the Retained in memory and Unattended execution
in the properties...  They'll, if anything lead you to the concepts
I mentioned earlier...  even if I don't really understand them myself,
I have a sneaking suspicion they have something to do with all this...

D.


Quote:
> Hello!

> this is a very typicall problem, regarding "AddressOf" Operator

> What i am doing is, having an ActiveX DLL which gives me Video Frame
passed
> by the VFW, using the Address of a procedure in a Public Module.

> i've sorted out the re-enterency by the hack provided in VBAccelerator. so
i
> can identify every object of the in-Process server.and call each object's
> Method to pass the frame up the tree.

> now i turned the ActiveX DLL into ActiveX Exe. When in the Design mode,
> running the EXE in VB IDE, it smoothly passes out the frames and i can
view
> them simultaniously. but when i compile it and run it as an EXE, outside
the
> VB IDE, it gets connected to the given Video Capture drivers and i also
> start to get the frames in different picture boxes. but the capture driver
> to which i connect earlier, stops responding, i mean and the second one
> shows frames smoothly.
> when i disconnect the second one.. the first one gets smooth again.

> what am i doing wrong here??

> pls help!!

> thanks in Advance
> Raju



Wed, 09 Feb 2005 14:01:20 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Pls help me again on how to autosize the richtextbox

2. Problem connecting to Access2000 database...pls, pls help.

3. Give me some hints pls, Help pls

4. Help pls, Give me some hints pls

5. PLS HELP!!! PLS HELP!!! PLS HELP!!!

6. Accesing a secure DB....HELP HELP PLS

7. Searching text in a file..PLS Help With this code..HELP

8. VBA on again off again

9. Help File Help (yet again...)

10. Printer object again and again

11. Again and Again, Bold text in a Listview

12. simple sql error again! pls help!

 

 
Powered by phpBB® Forum Software