Error: the object invoked has disconnected from its clients 
Author Message
 Error: the object invoked has disconnected from its clients

We try our app in about 200 PC with XP or Vista and its working fine. Today
we installed the app in a laptop with Vista and we are getting the error: the
object invoked has disconnected from its clients.
I tryied a search in web but everyone talking about databases. The only
thing the program does at load_form is to call the fuction GetUserName

Any ideas?



Wed, 11 May 2011 03:20:01 GMT  
 Error: the object invoked has disconnected from its clients
Hi Kostas,



Quote:
> We try our app in about 200 PC with XP or Vista and its working fine.
> Today
> we installed the app in a laptop with Vista and we are getting the error:
> the
> object invoked has disconnected from its clients.
> I tryied a search in web but everyone talking about databases. The only
> thing the program does at load_form is to call the fuction GetUserName

> Any ideas?

Are you launching that by right clicking and selecting Run As Administrator
? Or is it running as a standard user ?


Wed, 11 May 2011 08:37:05 GMT  
 Error: the object invoked has disconnected from its clients
If I remember this correctly it's more of an automation issue. You have to
better explain what you are doing and with what you are doing it with, such
as dll and ocx used.

--
Randem Systems
The Top Inno Setup Script Generator
http://www.randem.com/innoscript.html
http://www.rndem.com/installerproblems.html
http://www.randem.com/vistainstalls.html
http://www.financialtrainingservices.org



Quote:
> We try our app in about 200 PC with XP or Vista and its working fine.
> Today
> we installed the app in a laptop with Vista and we are getting the error:
> the
> object invoked has disconnected from its clients.
> I tryied a search in web but everyone talking about databases. The only
> thing the program does at load_form is to call the fuction GetUserName

> Any ideas?



Wed, 11 May 2011 11:14:08 GMT  
 Error: the object invoked has disconnected from its clients

Quote:
> We try our app in about 200 PC with XP or Vista and its working fine.
Today
> we installed the app in a laptop with Vista and we are getting the error:
the
> object invoked has disconnected from its clients.
> I tryied a search in web but everyone talking about databases. The only
> thing the program does at load_form is to call the fuction GetUserName

> Any ideas?

 As Randem said, you need to provide more
details. That error sounds like it's coming from
an ActiveX EXE, but you didn't mention that.


Wed, 11 May 2011 12:01:13 GMT  
 Error: the object invoked has disconnected from its clients
Hello, thank you for the answers.
As i told you the only think the program does its when opening to call the
function GetUserName.
It uses the function gust to fill a textbox with the current user name.
The only control that we are using is the winsock control.
And yes its an Automation error.
I tried both run as administrator and not
I also tried to disable user account control and install it again but with
no luck.
Tha strange thing is that the program works fine in other pc's with every OS
Quote:

> > We try our app in about 200 PC with XP or Vista and its working fine.
> Today
> > we installed the app in a laptop with Vista and we are getting the error:
> the
> > object invoked has disconnected from its clients.
> > I tryied a search in web but everyone talking about databases. The only
> > thing the program does at load_form is to call the fuction GetUserName

> > Any ideas?

>  As Randem said, you need to provide more
> details. That error sounds like it's coming from
> an ActiveX EXE, but you didn't mention that.



Wed, 11 May 2011 15:03:00 GMT  
 Error: the object invoked has disconnected from its clients



Quote:
> Hello, thank you for the answers.
> As i told you the only think the program does its when opening to call the
> function GetUserName.
> It uses the function gust to fill a textbox with the current user name.
> The only control that we are using is the winsock control.
> And yes its an Automation error.
> I tried both run as administrator and not
> I also tried to disable user account control and install it again but with
> no luck.
> Tha strange thing is that the program works fine in other pc's with every
OS

lol, I love how things get revealed slowly...

Now we know you are using a Winsock control.
We can guess the error occurs on launch because you mentioned the code you
wrote in Form_Load. But that is not the only possible point of failure - A
lot is going on while VB loads a Form before the Form_Load event.

This error is happening because either your app is dereferencing an alias to
a null object (un-instanced coclass) or the service (the object) has
terminated or become unavailable unexpectedly. (Both essentially the same
thing.)

Since it works well elsewhere then one has to suspect the laptop has either
an incorrect version of winsock, or is somehow delaying its instantiation,
or prematurely killing it.

Re-install the control and any SPs for the laptop. (Perhaps even re-install
or repair Vista) Make sure there is only one copy of the control on the
laptop, clean the Registry, etc.

or perhaps there is some additional information you would like to share.

-ralph



Wed, 11 May 2011 15:53:49 GMT  
 Error: the object invoked has disconnected from its clients
Yes, I thought it would be the Winsock control but you never mentioned you
used it. Try not to use controls like that inn the Form_Load event. As I
mentioned the events do not always happen in the order you expect. If you
used the app I mentioned you would see exactly the order the events happen
and you might be surprised what is happening leading to a correction.

--
Randem Systems
The Top Inno Setup Script Generator
http://www.randem.com/innoscript.html
http://www.rndem.com/installerproblems.html
http://www.randem.com/vistainstalls.html
http://www.financialtrainingservices.org



Quote:
> Hello, thank you for the answers.
> As i told you the only think the program does its when opening to call the
> function GetUserName.
> It uses the function gust to fill a textbox with the current user name.
> The only control that we are using is the winsock control.
> And yes its an Automation error.
> I tried both run as administrator and not
> I also tried to disable user account control and install it again but with
> no luck.
> Tha strange thing is that the program works fine in other pc's with every
> OS


>> > We try our app in about 200 PC with XP or Vista and its working fine.
>> Today
>> > we installed the app in a laptop with Vista and we are getting the
>> > error:
>> the
>> > object invoked has disconnected from its clients.
>> > I tryied a search in web but everyone talking about databases. The only
>> > thing the program does at load_form is to call the fuction GetUserName

>> > Any ideas?

>>  As Randem said, you need to provide more
>> details. That error sounds like it's coming from
>> an ActiveX EXE, but you didn't mention that.



Wed, 11 May 2011 17:20:24 GMT  
 
 [ 7 post ] 

 Relevant Pages 

1. INet Error: Automation Error - The object invoked has disconnected from its clients

2. VsFlexGrid Pro 7.0.0.78 + Automation error- The object invoked has disconnected from its clients

3. VsFlexGrid Pro 7.0.0.78 + Automation error- The object invoked has disconnected from its clients

4. The object invoked has disconnected from one of its clients: Automation error -2147417848

5. Error # -2147417848:The Object Invoked has disconnected from its clients

6. object invoked has disconnected from its clients

7. The object invoked has disconnected from its clients

8. The object invoked has disconnected from its clients

9. The object invoked has disconnected from its clients.

10. Newbie: Object invoked has disconnected from its clients

11. The object invoked has disconnected from its clients

12. the object invoked has disconnected from its clients

 

 
Powered by phpBB® Forum Software