Problems with my ActiveX controls 
Author Message
 Problems with my ActiveX controls

I've written a couple of ActiveX controls, and an application program that
uses them. Everything has been fine on the development PC. I can run them in
test mode, install them, run the application, etc.

However, when I install the ActiveX controls on another PC, I get Run-time
error 440 (Automation Error), and run-time error 429 (ActiveX component
can't create object). I have very little experience with this stuff, the
error messages are pretty cryptic, and the VB docs don't help. I can thrash
around randomly, but I have really no idea where to go from here. If anyone
has experience with this problem, I'd appreciate some pointers.

FWIW I'm using VB5, and I create installation scripts with the Application
Setup wizard. Platform is Win98.

I'd appreciate a cc to "dtaylor at pctc.com" if possible (make the obvious
replacement to the email address).

TIA



Fri, 07 Sep 2001 03:00:00 GMT  
 Problems with my ActiveX controls
I think the cause of your your problem is that the controls's are not
registered correctly on the other pc.
Suppose the name of your control is 'test.ocx'. you can try registering the
control manually by typing 'regsvr32 test.ocx' at the command line.
If the application which uses this control is working fine now, you have
a problem in your setup application. maybe there's an option 'automaticly
register controls' or something like that.


Quote:
>I've written a couple of ActiveX controls, and an application program that
>uses them. Everything has been fine on the development PC. I can run them
in
>test mode, install them, run the application, etc.

>However, when I install the ActiveX controls on another PC, I get Run-time
>error 440 (Automation Error), and run-time error 429 (ActiveX component
>can't create object). I have very little experience with this stuff, the
>error messages are pretty cryptic, and the VB docs don't help. I can thrash
>around randomly, but I have really no idea where to go from here. If anyone
>has experience with this problem, I'd appreciate some pointers.

>FWIW I'm using VB5, and I create installation scripts with the Application
>Setup wizard. Platform is Win98.

>I'd appreciate a cc to "dtaylor at pctc.com" if possible (make the obvious
>replacement to the email address).

>TIA



Fri, 07 Sep 2001 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Problem with an ActiveX Control (OCX) in an ASP page

2. Problems with homemade ActiveX control and Internet Explorer

3. Problem with registering ActiveX-Controls

4. Problem with my ActiveX control.

5. problem embedding custom activeX controls

6. Problem with an ActiveX Control (OCX) in an ASP page

7. Problem deploying signed ActiveX Control on a web server

8. Problems with my ActiveX controls of my vb version

9. Problems with loading ActiveX control made in VC++ 6.0 using MFC

10. Problem deploying signed ActiveX Control on a web server

11. Problem with an ActiveX Control

12. Problem with an ActiveX control !

 

 
Powered by phpBB® Forum Software