Some triangles not rendered in Direct3D 8 - 2 attachments 
Author Message
 Some triangles not rendered in Direct3D 8 - 2 attachments

this looks like bad data.

are you using indexed triangles or just a simple list? if indexed, it could
be an index problem, if not its probably in the data.

try breaking the data apart until you find a segment with just one missing
triangle, then you can isolate the vertices that are causing the problem and
determine if its a data problem.

the debug runtime probably doesnt include any additional output right? that
would also indicate a data problem.


Quote:
> Hi there. Im a newbie in direct3d and i want to know if someone can help
> me.

> I loaded a list o triagles with direct 3D, but, depending how my camera is
> positioned some triangles are not rendered. even if i set the CULLMODE to
> none. I have attached to small screenshots to show better.

> I appreciate if someone could help me.

> Thanks.

> PS: Since it's my first time here, plese tell me if it's not allowed to
> attach screenshots in posts.

> PS2: Sorry my really bad english.

----------------------------------------------------------------------------
----

- Show quoted text -



Sun, 01 Jan 2006 23:57:51 GMT  
 Some triangles not rendered in Direct3D 8 - 2 attachments


I got the data from a 3DFace autocad file.

im rendering with a triangle list

D3DDevice.DrawPrimitiveUP D3DPT_TRIANGLELIST, TotalReg, lVertex(0), Len
(lVertex(0))

the strange is that sometimes it draws right and sometimes not.

Quote:
> this looks like bad data.

> are you using indexed triangles or just a simple list? if indexed, it
> could be an index problem, if not its probably in the data.

> try breaking the data apart until you find a segment with just one
> missing triangle, then you can isolate the vertices that are causing
> the problem and determine if its a data problem.

> the debug runtime probably doesnt include any additional output right?
> that would also indicate a data problem.



Mon, 02 Jan 2006 00:15:57 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. fax service can not render attachment from VB or PB

2. direct3d drawing triangles...

3. Subreport Not Linking / Not Rendering

4. Direct3D 8.1: Problem with Direct3D application

5. Attachments.remove is not removing attachment

6. URG!!!:Multipage not rendering controls properly

7. Automated (VBA) FAX will not render

8. Render XML+XSL into PrintDocument (not XML) ?

9. in WinXP, VB6 Scrollbar control does not render in XP Style

10. ActiveX control not rendered correctly in IE

11. 'Could not render all attachments' problem in Win2K

12. report as attachment not working

 

 
Powered by phpBB® Forum Software