EnumHosts fails... 
Author Message
 EnumHosts fails...

I'm using VB DirectPlay (DirectX 8.1) to set up a
communication in a LAN. (Not the internet!)

The method to search for a host on another machine that
I’m using is 'EnumHosts'.
Like this:
        TimerExpire.Enabled = True
        mlEnumAsync = moDPP.EnumHosts(Desc, dph, moDPA,
ByVal 0&, 0)

Just before I’m starting a timer, which looks periodically
if DirectPlay found a host.
After a certain amount of trials and still no Host is
being found, I cancel the search with:
            If mlEnumAsync <> 0 Then
moDPP.CancelAsyncOperation mlEnumAsync, 0

Then I run the application on three different computers
connected in a LAN belonging all three to the same Domain.
Computer A runs windows 2000
Computer B and C run windows 98

Computer A and B are working perfectly well.
Computer C starts the EnumHosts and the first Computer it
wants to test for a host is A.
At that point the application stops running on C and there
is no response anymore.
Also the timer which I started doesn't get any process
time anymore.

Does somebody know this problem?
Is it a LAN setting? An operating system problem?
Are there some other properties in DirectPlay that are
needed or
Should I use EnumHosts differently?


Fri, 24 Dec 2004 19:29:05 GMT  
 [ 1 post ] 

 Relevant Pages 

1. Connection Fail after installation - dbnmpntw write() connection fail

2. Connection Fail after installation - dbnmpntw write() connection fail

3. ASP Export to PDF Failing....(Hair failing out)

4. DCPromo fails with "Failed to create GPO"

5. fails! - PEAddParameterCurrentRange using pe api fails!

6. creation of excel speadshhet fails

7. Synchronization Failed - problem

8. Implements keyword failing *sometimes*

9. tabledef sourcetable failing

10. shell command fails on XP, OK on Win98

11. Skip labels fails when I print!

12. SendObject fails


Powered by phpBB® Forum Software