D3DERR_INVALIDCALL ... can anybody help me? 
Author Message
 D3DERR_INVALIDCALL ... can anybody help me?

Hi to everyone here in this group,

I face a strange problem in my rendering function and hope, somebody here
will be able to help me.
O.K. here we go!

The render routine of my graphics class goes like this:

    device.Clear 0, ByVal 0, D3DCLEAR_TARGET, &HFFFFFF, 1#, 0
    'device is a valid D3DDevice
    'note that I don't get any error message neither in debug output,
    'nor in my own error handler.
    'But for now, it doesn't clear anything

    device.CopyRects surfPic, ByVal 0, 0, surfBack, ByVal 0
    'I want a large background image, that's why I do this.
    'It did work in earlier versions of the class module,
    'but doesn't work for now. I didn't find the clue
    'But I still don't get any error message.

    device.BeginScene

    device.SetRenderState D3DRS_CULLMODE, D3DCULL_NONE
    device.SetRenderState D3DRS_LIGHTING, 0
    'my customvertexformat is prelit.

    device.SetStreamSource 0, LineBuffer, Len(Line_Vertex(1))
    'LineBuffer is a valid D3DVertexBuffer8, Line_Vertex() is an array
    'containing 8 vertices of my Flexible Vertex Format

    device.SetVertexShader FVF_Line_PitVertex
    'FVF_Line_PitVertex is defined as
    'Const FVF_Line_PitVertex = (D3DFVF_XYZ Or D3DFVF_DIFFUSE)

Until now the debug runtime says:

1780: Direct3D8: (INFO) :======================= Hal SWVP device selected
1780:
1780: Direct3D8: :DoneExclusiveMode
1780: Direct3D8: (INFO) :HalDevice Driver Style 6
1780:
1780: Direct3D8: (INFO) :Using WLMT PSGP
1780:

Everything seems to be OK

Now I call:
        device.DrawPrimitive D3DPT_LINELIST, 0, 8

... and get the following debug output:

1780: Direct3D8: (ERROR) :*** Exception in
d:\builds\nt32_chk\multimedia\directx\dxg\d3d8\fe\vshader.cpp Line: 624
1780:
1780: Direct3D8: (ERROR) :Stream 0 should be initialized for FVF shaders
1780:
1780: Direct3D8: (ERROR) :DrawPrimitive failed.
1780:
1780: Direct3D8: (ERROR) :Unsupported Interface identifier passed to
QueryInterface for IDirect3DDevice8
1780: Direct3D8: (ERROR) :Unsupported Interface identifier passed to
QueryInterface for IDirect3DDevice8

My own debugging routine catches the error code. It reads: -2.005.530.516
(8876086C)
ErrorLookup says this is D3DERR_INVALIDCALL

Does anybody have an idea? What am I doing wrong?

____________________________

Greetings out of {*filter*}space,
mondspeer


Many men wanted to become god!
But only one god wanted to become man!
Jesus rulez.



Tue, 19 Apr 2005 13:19:20 GMT  
 D3DERR_INVALIDCALL ... can anybody help me?
Ah ... and by the way: If I try to run on REFRAST, the whole thing chrashes
when I try to call

Quote:
>     device.CopyRects surfPic, ByVal 0, 0, surfBack, ByVal 0

This is weird, isn't it?

Hi Rich ... yes I know, if it chrashes the REFRAST, my code has to be
faulty, but I don't know where.

______________________

Greetings out of {*filter*}space,
Mondspeer


Many men wanted to become god,
but only one god wanted to become man.
Jesus rulez.



Tue, 19 Apr 2005 15:26:28 GMT  
 D3DERR_INVALIDCALL ... can anybody help me?
does the debug runtime provide any output?

where and how does it crash in the de{*filter*}?

--
Phil Taylor


Quote:
> Ah ... and by the way: If I try to run on REFRAST, the whole thing
chrashes
> when I try to call

> >     device.CopyRects surfPic, ByVal 0, 0, surfBack, ByVal 0

> This is weird, isn't it?

> Hi Rich ... yes I know, if it chrashes the REFRAST, my code has to be
> faulty, but I don't know where.

> ______________________

> Greetings out of {*filter*}space,
> Mondspeer


> Many men wanted to become god,
> but only one god wanted to become man.
> Jesus rulez.



Wed, 20 Apr 2005 00:02:18 GMT  
 D3DERR_INVALIDCALL ... can anybody help me?
Hi Phil,

I posted all debug output in my first post:

// For the first question, I repost some of the code:

The render routine of my graphics class goes like this:

    device.Clear 0, ByVal 0, D3DCLEAR_TARGET, &HFFFFFF, 1#, 0
    'device is a valid D3DDevice
    'note that I don't get any error message neither in debug output,
    'nor in my own error handler.
    'But for now, it doesn't clear anything

    device.CopyRects surfPic, ByVal 0, 0, surfBack, ByVal 0
    'I want a large background image, that's why I do this.
    'It did work in earlier versions of the class module,
    'but doesn't work for now. I didn't find the clue
    'But I still don't get any error message.

    device.BeginScene

    device.SetRenderState D3DRS_CULLMODE, D3DCULL_NONE
    device.SetRenderState D3DRS_LIGHTING, 0
    'my customvertexformat is prelit.

    device.SetStreamSource 0, LineBuffer, Len(Line_Vertex(1))
    'LineBuffer is a valid D3DVertexBuffer8, Line_Vertex() is an array
    'containing 8 vertices of my Flexible Vertex Format

    device.SetVertexShader FVF_Line_PitVertex
    'FVF_Line_PitVertex is defined as
    'Const FVF_Line_PitVertex = (D3DFVF_XYZ Or D3DFVF_DIFFUSE)

Until now the debug runtime says:

1780: Direct3D8: (INFO) :======================= Hal SWVP device selected
1780:
1780: Direct3D8: :DoneExclusiveMode
1780: Direct3D8: (INFO) :HalDevice Driver Style 6
1780:
1780: Direct3D8: (INFO) :Using WLMT PSGP
1780:

Everything seems to be OK

Now I call:
        device.DrawPrimitive D3DPT_LINELIST, 0, 8

... and get the following debug output:

1780: Direct3D8: (ERROR) :*** Exception in
d:\builds\nt32_chk\multimedia\directx\dxg\d3d8\fe\vshader.cpp Line: 624
1780:
1780: Direct3D8: (ERROR) :Stream 0 should be initialized for FVF shaders
1780:
1780: Direct3D8: (ERROR) :DrawPrimitive failed.
1780:
1780: Direct3D8: (ERROR) :Unsupported Interface identifier passed to
QueryInterface for IDirect3DDevice8
1780: Direct3D8: (ERROR) :Unsupported Interface identifier passed to
QueryInterface for IDirect3DDevice8

My own debugging routine catches the error code. It reads: -2.005.530.516
(8876086C)
ErrorLookup says this is D3DERR_INVALIDCALL

This is for the first question about the debug output.
(it happens on HAL)

Any idea? What am I doing wrong?

// To the second question:

    When I turn to REFRAST (Or at least I try to) ...
    it crashes on the line:

    >     device.CopyRects surfPic, ByVal 0, 0, surfBack, ByVal 0

    And I don't get any debug output. Even my ErrorHandler doesn't show
anything.
   Any Idea about this?

--

Greetings out of {*filter*}space,
Mondspeer




Wed, 20 Apr 2005 15:54:35 GMT  
 D3DERR_INVALIDCALL ... can anybody help me?
doesnt the matrices tutorial use exactly this FVF format, amonst other VB
samples in the SDK that use xyz and diffuse as well as 1 set of tex coords?

do they work on your config?

if so, then what are the SDK examples doing differently from your code?

--
Phil Taylor


Quote:
> Hi Phil,

> I posted all debug output in my first post:

> // For the first question, I repost some of the code:

> The render routine of my graphics class goes like this:

>     device.Clear 0, ByVal 0, D3DCLEAR_TARGET, &HFFFFFF, 1#, 0
>     'device is a valid D3DDevice
>     'note that I don't get any error message neither in debug output,
>     'nor in my own error handler.
>     'But for now, it doesn't clear anything

>     device.CopyRects surfPic, ByVal 0, 0, surfBack, ByVal 0
>     'I want a large background image, that's why I do this.
>     'It did work in earlier versions of the class module,
>     'but doesn't work for now. I didn't find the clue
>     'But I still don't get any error message.

>     device.BeginScene

>     device.SetRenderState D3DRS_CULLMODE, D3DCULL_NONE
>     device.SetRenderState D3DRS_LIGHTING, 0
>     'my customvertexformat is prelit.

>     device.SetStreamSource 0, LineBuffer, Len(Line_Vertex(1))
>     'LineBuffer is a valid D3DVertexBuffer8, Line_Vertex() is an array
>     'containing 8 vertices of my Flexible Vertex Format

>     device.SetVertexShader FVF_Line_PitVertex
>     'FVF_Line_PitVertex is defined as
>     'Const FVF_Line_PitVertex = (D3DFVF_XYZ Or D3DFVF_DIFFUSE)

> Until now the debug runtime says:

> 1780: Direct3D8: (INFO) :======================= Hal SWVP device selected
> 1780:
> 1780: Direct3D8: :DoneExclusiveMode
> 1780: Direct3D8: (INFO) :HalDevice Driver Style 6
> 1780:
> 1780: Direct3D8: (INFO) :Using WLMT PSGP
> 1780:

> Everything seems to be OK

> Now I call:
>         device.DrawPrimitive D3DPT_LINELIST, 0, 8

> ... and get the following debug output:

> 1780: Direct3D8: (ERROR) :*** Exception in
> d:\builds\nt32_chk\multimedia\directx\dxg\d3d8\fe\vshader.cpp Line: 624
> 1780:
> 1780: Direct3D8: (ERROR) :Stream 0 should be initialized for FVF shaders
> 1780:
> 1780: Direct3D8: (ERROR) :DrawPrimitive failed.
> 1780:
> 1780: Direct3D8: (ERROR) :Unsupported Interface identifier passed to
> QueryInterface for IDirect3DDevice8
> 1780: Direct3D8: (ERROR) :Unsupported Interface identifier passed to
> QueryInterface for IDirect3DDevice8

> My own debugging routine catches the error code. It reads: -2.005.530.516
> (8876086C)
> ErrorLookup says this is D3DERR_INVALIDCALL

> This is for the first question about the debug output.
> (it happens on HAL)

> Any idea? What am I doing wrong?

> // To the second question:

>     When I turn to REFRAST (Or at least I try to) ...
>     it crashes on the line:

>     >     device.CopyRects surfPic, ByVal 0, 0, surfBack, ByVal 0

>     And I don't get any debug output. Even my ErrorHandler doesn't show
> anything.
>    Any Idea about this?

> --

> Greetings out of {*filter*}space,
> Mondspeer





Thu, 21 Apr 2005 04:27:26 GMT  
 D3DERR_INVALIDCALL ... can anybody help me?
Hi Phil,

I have to quit my coding for a few days.
When I come back, I will check this out and post again.

Thanks for your help.

--

______________________

Greetings out of {*filter*}space,
Mondspeer


Many men wanted to become god,
but only one god wanted to become man.
Jesus rulez.



Quote:
> doesnt the matrices tutorial use exactly this FVF format, amonst other VB
> samples in the SDK that use xyz and diffuse as well as 1 set of tex
coords?

> do they work on your config?

> if so, then what are the SDK examples doing differently from your code?

> --
> Phil Taylor



> > Hi Phil,

> > I posted all debug output in my first post:

> > // For the first question, I repost some of the code:

> > The render routine of my graphics class goes like this:

> >     device.Clear 0, ByVal 0, D3DCLEAR_TARGET, &HFFFFFF, 1#, 0
> >     'device is a valid D3DDevice
> >     'note that I don't get any error message neither in debug output,
> >     'nor in my own error handler.
> >     'But for now, it doesn't clear anything

> >     device.CopyRects surfPic, ByVal 0, 0, surfBack, ByVal 0
> >     'I want a large background image, that's why I do this.
> >     'It did work in earlier versions of the class module,
> >     'but doesn't work for now. I didn't find the clue
> >     'But I still don't get any error message.

> >     device.BeginScene

> >     device.SetRenderState D3DRS_CULLMODE, D3DCULL_NONE
> >     device.SetRenderState D3DRS_LIGHTING, 0
> >     'my customvertexformat is prelit.

> >     device.SetStreamSource 0, LineBuffer, Len(Line_Vertex(1))
> >     'LineBuffer is a valid D3DVertexBuffer8, Line_Vertex() is an array
> >     'containing 8 vertices of my Flexible Vertex Format

> >     device.SetVertexShader FVF_Line_PitVertex
> >     'FVF_Line_PitVertex is defined as
> >     'Const FVF_Line_PitVertex = (D3DFVF_XYZ Or D3DFVF_DIFFUSE)

> > Until now the debug runtime says:

> > 1780: Direct3D8: (INFO) :======================= Hal SWVP device
selected
> > 1780:
> > 1780: Direct3D8: :DoneExclusiveMode
> > 1780: Direct3D8: (INFO) :HalDevice Driver Style 6
> > 1780:
> > 1780: Direct3D8: (INFO) :Using WLMT PSGP
> > 1780:

> > Everything seems to be OK

> > Now I call:
> >         device.DrawPrimitive D3DPT_LINELIST, 0, 8

> > ... and get the following debug output:

> > 1780: Direct3D8: (ERROR) :*** Exception in
> > d:\builds\nt32_chk\multimedia\directx\dxg\d3d8\fe\vshader.cpp Line: 624
> > 1780:
> > 1780: Direct3D8: (ERROR) :Stream 0 should be initialized for FVF shaders
> > 1780:
> > 1780: Direct3D8: (ERROR) :DrawPrimitive failed.
> > 1780:
> > 1780: Direct3D8: (ERROR) :Unsupported Interface identifier passed to
> > QueryInterface for IDirect3DDevice8
> > 1780: Direct3D8: (ERROR) :Unsupported Interface identifier passed to
> > QueryInterface for IDirect3DDevice8

> > My own debugging routine catches the error code. It

reads: -2.005.530.516

- Show quoted text -

Quote:
> > (8876086C)
> > ErrorLookup says this is D3DERR_INVALIDCALL

> > This is for the first question about the debug output.
> > (it happens on HAL)

> > Any idea? What am I doing wrong?

> > // To the second question:

> >     When I turn to REFRAST (Or at least I try to) ...
> >     it crashes on the line:

> >     >     device.CopyRects surfPic, ByVal 0, 0, surfBack, ByVal 0

> >     And I don't get any debug output. Even my ErrorHandler doesn't show
> > anything.
> >    Any Idea about this?

> > --

> > Greetings out of {*filter*}space,
> > Mondspeer





Fri, 22 Apr 2005 15:34:02 GMT  
 D3DERR_INVALIDCALL ... can anybody help me?
D3DERR_INVALIDCALL is an argument error.

If I remember in the DrawPrimitive call the parameter is the number of
*primitives*. You may want to try 7 instead. You have a list of 7 lines made
with 8 vertices...

Patrice



Quote:
> Hi to everyone here in this group,

> I face a strange problem in my rendering function and hope, somebody here
> will be able to help me.
> O.K. here we go!

> The render routine of my graphics class goes like this:

>     device.Clear 0, ByVal 0, D3DCLEAR_TARGET, &HFFFFFF, 1#, 0
>     'device is a valid D3DDevice
>     'note that I don't get any error message neither in debug output,
>     'nor in my own error handler.
>     'But for now, it doesn't clear anything

>     device.CopyRects surfPic, ByVal 0, 0, surfBack, ByVal 0
>     'I want a large background image, that's why I do this.
>     'It did work in earlier versions of the class module,
>     'but doesn't work for now. I didn't find the clue
>     'But I still don't get any error message.

>     device.BeginScene

>     device.SetRenderState D3DRS_CULLMODE, D3DCULL_NONE
>     device.SetRenderState D3DRS_LIGHTING, 0
>     'my customvertexformat is prelit.

>     device.SetStreamSource 0, LineBuffer, Len(Line_Vertex(1))
>     'LineBuffer is a valid D3DVertexBuffer8, Line_Vertex() is an array
>     'containing 8 vertices of my Flexible Vertex Format

>     device.SetVertexShader FVF_Line_PitVertex
>     'FVF_Line_PitVertex is defined as
>     'Const FVF_Line_PitVertex = (D3DFVF_XYZ Or D3DFVF_DIFFUSE)

> Until now the debug runtime says:

> 1780: Direct3D8: (INFO) :======================= Hal SWVP device selected
> 1780:
> 1780: Direct3D8: :DoneExclusiveMode
> 1780: Direct3D8: (INFO) :HalDevice Driver Style 6
> 1780:
> 1780: Direct3D8: (INFO) :Using WLMT PSGP
> 1780:

> Everything seems to be OK

> Now I call:
>         device.DrawPrimitive D3DPT_LINELIST, 0, 8

> ... and get the following debug output:

> 1780: Direct3D8: (ERROR) :*** Exception in
> d:\builds\nt32_chk\multimedia\directx\dxg\d3d8\fe\vshader.cpp Line: 624
> 1780:
> 1780: Direct3D8: (ERROR) :Stream 0 should be initialized for FVF shaders
> 1780:
> 1780: Direct3D8: (ERROR) :DrawPrimitive failed.
> 1780:
> 1780: Direct3D8: (ERROR) :Unsupported Interface identifier passed to
> QueryInterface for IDirect3DDevice8
> 1780: Direct3D8: (ERROR) :Unsupported Interface identifier passed to
> QueryInterface for IDirect3DDevice8

> My own debugging routine catches the error code. It reads: -2.005.530.516
> (8876086C)
> ErrorLookup says this is D3DERR_INVALIDCALL

> Does anybody have an idea? What am I doing wrong?

> ____________________________

> Greetings out of {*filter*}space,
> mondspeer


> Many men wanted to become god!
> But only one god wanted to become man!
> Jesus rulez.



Tue, 26 Apr 2005 00:53:55 GMT  
 D3DERR_INVALIDCALL ... can anybody help me?
Hi Patrice,

no ... that's not quite correct.

I have a list of 4 lines, made of 8 vertices (using Linelist, not
Linestrip).
But nevertheless, I'm going to try.

I would have to render 4 primitives. I'll post the results.

--

______________________

Greetings out of {*filter*}space,
Mondspeer


Many men wanted to become god,
but only one god wanted to become man.
Jesus rulez.



Quote:
> D3DERR_INVALIDCALL is an argument error.

> If I remember in the DrawPrimitive call the parameter is the number of
> *primitives*. You may want to try 7 instead. You have a list of 7 lines
made
> with 8 vertices...

> Patrice



> > Hi to everyone here in this group,

> > I face a strange problem in my rendering function and hope, somebody
here
> > will be able to help me.
> > O.K. here we go!

> > The render routine of my graphics class goes like this:

> >     device.Clear 0, ByVal 0, D3DCLEAR_TARGET, &HFFFFFF, 1#, 0
> >     'device is a valid D3DDevice
> >     'note that I don't get any error message neither in debug output,
> >     'nor in my own error handler.
> >     'But for now, it doesn't clear anything

> >     device.CopyRects surfPic, ByVal 0, 0, surfBack, ByVal 0
> >     'I want a large background image, that's why I do this.
> >     'It did work in earlier versions of the class module,
> >     'but doesn't work for now. I didn't find the clue
> >     'But I still don't get any error message.

> >     device.BeginScene

> >     device.SetRenderState D3DRS_CULLMODE, D3DCULL_NONE
> >     device.SetRenderState D3DRS_LIGHTING, 0
> >     'my customvertexformat is prelit.

> >     device.SetStreamSource 0, LineBuffer, Len(Line_Vertex(1))
> >     'LineBuffer is a valid D3DVertexBuffer8, Line_Vertex() is an array
> >     'containing 8 vertices of my Flexible Vertex Format

> >     device.SetVertexShader FVF_Line_PitVertex
> >     'FVF_Line_PitVertex is defined as
> >     'Const FVF_Line_PitVertex = (D3DFVF_XYZ Or D3DFVF_DIFFUSE)

> > Until now the debug runtime says:

> > 1780: Direct3D8: (INFO) :======================= Hal SWVP device
selected
> > 1780:
> > 1780: Direct3D8: :DoneExclusiveMode
> > 1780: Direct3D8: (INFO) :HalDevice Driver Style 6
> > 1780:
> > 1780: Direct3D8: (INFO) :Using WLMT PSGP
> > 1780:

> > Everything seems to be OK

> > Now I call:
> >         device.DrawPrimitive D3DPT_LINELIST, 0, 8

> > ... and get the following debug output:

> > 1780: Direct3D8: (ERROR) :*** Exception in
> > d:\builds\nt32_chk\multimedia\directx\dxg\d3d8\fe\vshader.cpp Line: 624
> > 1780:
> > 1780: Direct3D8: (ERROR) :Stream 0 should be initialized for FVF shaders
> > 1780:
> > 1780: Direct3D8: (ERROR) :DrawPrimitive failed.
> > 1780:
> > 1780: Direct3D8: (ERROR) :Unsupported Interface identifier passed to
> > QueryInterface for IDirect3DDevice8
> > 1780: Direct3D8: (ERROR) :Unsupported Interface identifier passed to
> > QueryInterface for IDirect3DDevice8

> > My own debugging routine catches the error code. It

reads: -2.005.530.516

- Show quoted text -

Quote:
> > (8876086C)
> > ErrorLookup says this is D3DERR_INVALIDCALL

> > Does anybody have an idea? What am I doing wrong?

> > ____________________________

> > Greetings out of {*filter*}space,
> > mondspeer


> > Many men wanted to become god!
> > But only one god wanted to become man!
> > Jesus rulez.



Tue, 26 Apr 2005 16:53:44 GMT  
 D3DERR_INVALIDCALL ... can anybody help me?
Ooops ! Sorry for this mistake, but I see that you get the idea ;-)



Quote:
> Hi Patrice,

> no ... that's not quite correct.

> I have a list of 4 lines, made of 8 vertices (using Linelist, not
> Linestrip).
> But nevertheless, I'm going to try.

> I would have to render 4 primitives. I'll post the results.

> --

> ______________________

> Greetings out of {*filter*}space,
> Mondspeer


> Many men wanted to become god,
> but only one god wanted to become man.
> Jesus rulez.



> > D3DERR_INVALIDCALL is an argument error.

> > If I remember in the DrawPrimitive call the parameter is the number of
> > *primitives*. You may want to try 7 instead. You have a list of 7 lines
> made
> > with 8 vertices...

> > Patrice



> > > Hi to everyone here in this group,

> > > I face a strange problem in my rendering function and hope, somebody
> here
> > > will be able to help me.
> > > O.K. here we go!

> > > The render routine of my graphics class goes like this:

> > >     device.Clear 0, ByVal 0, D3DCLEAR_TARGET, &HFFFFFF, 1#, 0
> > >     'device is a valid D3DDevice
> > >     'note that I don't get any error message neither in debug output,
> > >     'nor in my own error handler.
> > >     'But for now, it doesn't clear anything

> > >     device.CopyRects surfPic, ByVal 0, 0, surfBack, ByVal 0
> > >     'I want a large background image, that's why I do this.
> > >     'It did work in earlier versions of the class module,
> > >     'but doesn't work for now. I didn't find the clue
> > >     'But I still don't get any error message.

> > >     device.BeginScene

> > >     device.SetRenderState D3DRS_CULLMODE, D3DCULL_NONE
> > >     device.SetRenderState D3DRS_LIGHTING, 0
> > >     'my customvertexformat is prelit.

> > >     device.SetStreamSource 0, LineBuffer, Len(Line_Vertex(1))
> > >     'LineBuffer is a valid D3DVertexBuffer8, Line_Vertex() is an array
> > >     'containing 8 vertices of my Flexible Vertex Format

> > >     device.SetVertexShader FVF_Line_PitVertex
> > >     'FVF_Line_PitVertex is defined as
> > >     'Const FVF_Line_PitVertex = (D3DFVF_XYZ Or D3DFVF_DIFFUSE)

> > > Until now the debug runtime says:

> > > 1780: Direct3D8: (INFO) :======================= Hal SWVP device
> selected
> > > 1780:
> > > 1780: Direct3D8: :DoneExclusiveMode
> > > 1780: Direct3D8: (INFO) :HalDevice Driver Style 6
> > > 1780:
> > > 1780: Direct3D8: (INFO) :Using WLMT PSGP
> > > 1780:

> > > Everything seems to be OK

> > > Now I call:
> > >         device.DrawPrimitive D3DPT_LINELIST, 0, 8

> > > ... and get the following debug output:

> > > 1780: Direct3D8: (ERROR) :*** Exception in
> > > d:\builds\nt32_chk\multimedia\directx\dxg\d3d8\fe\vshader.cpp Line:
624
> > > 1780:
> > > 1780: Direct3D8: (ERROR) :Stream 0 should be initialized for FVF
shaders
> > > 1780:
> > > 1780: Direct3D8: (ERROR) :DrawPrimitive failed.
> > > 1780:
> > > 1780: Direct3D8: (ERROR) :Unsupported Interface identifier passed to
> > > QueryInterface for IDirect3DDevice8
> > > 1780: Direct3D8: (ERROR) :Unsupported Interface identifier passed to
> > > QueryInterface for IDirect3DDevice8

> > > My own debugging routine catches the error code. It
> reads: -2.005.530.516
> > > (8876086C)
> > > ErrorLookup says this is D3DERR_INVALIDCALL

> > > Does anybody have an idea? What am I doing wrong?

> > > ____________________________

> > > Greetings out of {*filter*}space,
> > > mondspeer


> > > Many men wanted to become god!
> > > But only one god wanted to become man!
> > > Jesus rulez.



Tue, 26 Apr 2005 23:22:39 GMT  
 
 [ 9 post ] 

 Relevant Pages 

1. Anybody have some good canned RTF routines (or class)?

2. How do I create a canned form?

3. Canned AcctReceivable Module needed!

4. Canned pages....

5. Cans access2.0 engine access btrieve files?

6. Crystal Reports Canned Code

7. Canned objects and/or images

8. Switching from inhouse software to canned package.

9. line graph in vb (canned routine)

10. 'Canned' data in VB program

11. Looking 4 Canned Control

12. License Error with OCX's anybody, anybody

 

 
Powered by phpBB® Forum Software