Can't register DLL directly into COM+ services 
Author Message
 Can't register DLL directly into COM+ services

I've created a COM+ app under VC++7.0 utilizing the ATL project wizard.
When using the wizard, I select Attributes, with support for COM+ 1.0 and
support component registrar.  After building the app and compiling, I get
the following error of "The typelib could not be found" when registering it
in COM+ services when trying to add the dll under "Install new components".
The MIDL is set up to create the type library, but it doesn't.  I can
however, register each interface component separately within the COM+
services using "Import components that are already registered".  Can anyone
point me in the right direction as to why this isn't working?

- Wilson



Mon, 16 Feb 2004 00:40:07 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. registering com+ service regsvcs

2. COM dll builds but doesn't register

3. COM dll's path has problem in register

4. ATL COM DLL won't register

5. why Can\'t create COM Instance After registering COM Server Successfully

6. Can call a VB ActiveX DLL's method using Invoke, but not directly

7. mfc dll doesn't register (I'm new at this)

8. mfc dll can't self-register (I'm new at this)

9. NT's SCM (for services) and COM's SCM (for locating and starting components)

10. active sync service provider and registering other DLLs

11. Suddenly can't register ATL COM class

12. _CrtIsValidHeapPointer failure while registering a COM dll built with /clr option

 

 
Powered by phpBB® Forum Software