LINK : fatal error LNK1000: unknown error 
Author Message
 LINK : fatal error LNK1000: unknown error

Hi All,

I have a solution with > 40 projects that has been built with VS7 since last
year with no problems.
Recently I added three new library projects.
The debug build completes without problems.
The release build (with symbols and /VERBOSE) fails with:
Finished pass 2
LINK : fatal error LNK1000: unknown error; consult documentation for
technical support options

The PDB file was being created the EXE was not.
Incremental linking is NOT being used.
No #pragma code_seg("section-name").

By a process of elimination I finally found that if I removed the
/PDBSTRIPPED option from the link it built again.
I then had a look at the target of the /PDBSTRIPPED option and deleted the
file.
After reinstating the /PDBSTRIPPED option the build started working again.

I assume that the target of the /PDBSTRIPPED option had got corrupted in
some way.
This is a rather unhelpful error.

Is this a known problem?

I hope that this post helps someone in the future.

Nick Kotarski



Mon, 08 Nov 2004 18:12:21 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. fatal error LNK1000: unknown error

2. LINK : fatal error LNK1000: Internal error during BuildImage

3. Link error, unknown file

4. LINK : fatal error LNK1561: entry point must be defined

5. Q: FATAL Linking error!!

6. VC++ .NET Fatal Link Error

7. LINK : fatal error LNK1561: entry point must be defined

8. Fatal link error?

9. LINK FATAL ERROR L1074 - gp exceeds 64K (VC++ 1.5)

10. HELP: Fatal Link Error

11. LINK : fatal error LNK1168: cannot open Debug/g1.ocx for writing

12. Linking...CVTRES : fatal error CVT1100: duplicate resource resource -- type:VERSION, name:1, language:0x0409

 

 
Powered by phpBB® Forum Software