Having problem with CRecordset under Visual C++ 7. 
Author Message
 Having problem with CRecordset under Visual C++ 7.

I have a legacy C++ application written under VC6 that I have changed to a
managed C++ application under VC7.  For some reason, I am having problems
with my CRecordSet objects when I try to read data from my access database.
None of the CString types are getting populated in the recordset.  The non
CString types are working fine.  Can someone explain what is wrong here and
how I can fix it?

--
-----------------------------------
Ken Varn
Senior Software Engineer
Diebold Inc.

-----------------------------------



Tue, 20 Sep 2005 06:27:01 GMT  
 Having problem with CRecordset under Visual C++ 7.

--------------------

Quote:


>Subject: Having problem with CRecordset under Visual C++ 7.
>Date: Thu, 3 Apr 2003 17:27:01 -0500
>Lines: 16
>Organization: Diebold Inc.
>X-Priority: 3
>X-MSMail-Priority: Normal
>X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
>X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106

>Newsgroups:

microsoft.public.dotnet.languages.vc,microsoft.public.dotnet.languages.vc.li
braries,microsoft.public.vc.mfc
Quote:
>NNTP-Posting-Host: 204.151.249.23
>Path:

cpmsftngxa08.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP11.
phx.gbl
Quote:
>Xref: cpmsftngxa08.phx.gbl

microsoft.public.dotnet.languages.vc.libraries:1749
microsoft.public.vc.mfc:367844 microsoft.public.dotnet.languages.vc:21765

Quote:
>X-Tomcat-NG: microsoft.public.dotnet.languages.vc

>I have a legacy C++ application written under VC6 that I have changed to a
>managed C++ application under VC7.  For some reason, I am having problems
>with my CRecordSet objects when I try to read data from my access database.
>None of the CString types are getting populated in the recordset.  The non
>CString types are working fine.  Can someone explain what is wrong here and
>how I can fix it?

>--
>-----------------------------------
>Ken Varn
>Senior Software Engineer
>Diebold Inc.

>-----------------------------------

Ken,

If you just recompile your VC6 project to VC7 in native code (not using
Managed Extensions) does your CRecordSet code work? I would suggest that
you do the native MFC6 to MFC7 conversion first, before recompiling the
code into MSIL with "Using Managed Extensions" (/clr compiler option)

--
Anson Tsao, Visual C++ Team
This posting is provided AS IS with no warranties, and confers no rights.



Tue, 27 Sep 2005 02:26:02 GMT  
 Having problem with CRecordset under Visual C++ 7.
I found out that the problem was not the recordset itself.  It was the VC7
de{*filter*}.  The de{*filter*} would show the String contents in the recordset as
being empty, but in fact they did contain the correct data.  I have
submitted this to the de{*filter*} group for investigation.

--
-----------------------------------
Ken Varn
Senior Software Engineer
Diebold Inc.

-----------------------------------


Quote:

> --------------------


> >Subject: Having problem with CRecordset under Visual C++ 7.
> >Date: Thu, 3 Apr 2003 17:27:01 -0500
> >Lines: 16
> >Organization: Diebold Inc.
> >X-Priority: 3
> >X-MSMail-Priority: Normal
> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106

> >Newsgroups:

microsoft.public.dotnet.languages.vc,microsoft.public.dotnet.languages.vc.li
Quote:
> braries,microsoft.public.vc.mfc
> >NNTP-Posting-Host: 204.151.249.23
> >Path:

cpmsftngxa08.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP11.
Quote:
> phx.gbl
> >Xref: cpmsftngxa08.phx.gbl
> microsoft.public.dotnet.languages.vc.libraries:1749
> microsoft.public.vc.mfc:367844 microsoft.public.dotnet.languages.vc:21765
> >X-Tomcat-NG: microsoft.public.dotnet.languages.vc

> >I have a legacy C++ application written under VC6 that I have changed to
a
> >managed C++ application under VC7.  For some reason, I am having problems
> >with my CRecordSet objects when I try to read data from my access
database.
> >None of the CString types are getting populated in the recordset.  The
non
> >CString types are working fine.  Can someone explain what is wrong here
and
> >how I can fix it?

> >--
> >-----------------------------------
> >Ken Varn
> >Senior Software Engineer
> >Diebold Inc.

> >-----------------------------------

> Ken,

> If you just recompile your VC6 project to VC7 in native code (not using
> Managed Extensions) does your CRecordSet code work? I would suggest that
> you do the native MFC6 to MFC7 conversion first, before recompiling the
> code into MSIL with "Using Managed Extensions" (/clr compiler option)

> --
> Anson Tsao, Visual C++ Team
> This posting is provided AS IS with no warranties, and confers no rights.



Tue, 27 Sep 2005 05:01:14 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Having problem with CRecordset under Visual C++ 7.

2. Having a problem printing Visual C++ Code

3. having problems with class viewer in Visual C++ 6.0

4. Having trouble with Crystal Reports for Visual C++

5. Having trouble with visual c++ automatic popup boxes

6. Having trouble with Crystal Reports for Visual C++

7. Visual C++ to eMbedded Visual C++ problem

8. Convert some I/O C++ code to C ---- having problems

9. having problems with bordeland c++ 5.0

10. Problem with Visual SourceSafe and Visual C++

11. problems with Visual C++ debugger and Visual J++

12. Visual C++/Visual Basic/COM Problem

 

 
Powered by phpBB® Forum Software