Communicating to an APPC program on an AS/400 
Author Message
 Communicating to an APPC program on an AS/400

I am having trouble communicating to an APPC program on an AS/400 with VB
CPIC Routines.  I am using the NSCPIC.DLL Library calls.  The first step I
do is CMINIT to initialize the communication.  It comes back with a return
code of 0(Meaning everything is OK).  I then setup parameter with various
calls.  The problem occurs when I do the CMALLC call.  It comes back with a
return code of 20(CM_PRODUCT_SPECIFIC_ERROR).  I have tried everything I
know(which is limited it seems) and I cannot seem to get the allocate to
return successfully.  If anyone has any example code or know anything I
could try I would deeply appreciate it.  I think my Job depends on it.

--
Carl Klingman
Lighthouse Technologies
http://www.*-*-*.com/



Mon, 20 May 2002 03:00:00 GMT  
 Communicating to an APPC program on an AS/400
Carl,

A product specific error on the CPI-C CMALLC call probably indicates a
problem with the side information table or interface on the PC side. I
believe the NS CPI-C support provides for a logging function. I forget
how to turn this on, but it can provide a lot of help. I assume that you
never get connected to the AS/400, right? Check the QSYSOPR message
queue to see if there are any error messages. The second level text on
these messages can provide some assistance.

Patrick
--
IBM AS/400 communications, FTP automation, and network security
software and consulting services.

http://www.patownsend.com

Quote:

> I am having trouble communicating to an APPC program on an AS/400 with VB
> CPIC Routines.  I am using the NSCPIC.DLL Library calls.  The first step I
> do is CMINIT to initialize the communication.  It comes back with a return
> code of 0(Meaning everything is OK).  I then setup parameter with various
> calls.  The problem occurs when I do the CMALLC call.  It comes back with a
> return code of 20(CM_PRODUCT_SPECIFIC_ERROR).  I have tried everything I
> know(which is limited it seems) and I cannot seem to get the allocate to
> return successfully.  If anyone has any example code or know anything I
> could try I would deeply appreciate it.  I think my Job depends on it.

> --
> Carl Klingman
> Lighthouse Technologies
> http://www.lhtech-inc.com



Wed, 22 May 2002 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Communicating to an APPC program on an AS/400

2. Communicating to an APPC program on an AS/400

3. ocx for APPC to AS/400 DB2?

4. VB 4.0 and APPC with AS/400

5. Call A Program on another Server - RPGLE program on an AS/400

6. Data Access Object/400 (DAO/400)

7. AS/400 DB2/400

8. AS/400 - Seeking info on using VB to access DB2/400

9. How execute a program in AS/400..?????? URGENT *****

10. Calling AS/400 CL Program using Client Access ODBC, VB, and ADO

11. call to a as/400 program

12. Running a program on the AS/400

 

 
Powered by phpBB® Forum Software