ODBC ver. 3.7 and ADO 1.5 problem 
Author Message
 ODBC ver. 3.7 and ADO 1.5 problem

Hi: there

      when we upgrade ODBC driver from 3.5 to 3.7, we can't connect with ADO
1.5, MSSQL is 7.0, what's the problem ?  Must we use ADO 2.0?

any advise will be appreciated

thanks

George



Sat, 16 Feb 2002 03:00:00 GMT  
 ODBC ver. 3.7 and ADO 1.5 problem
George - it should work ok.  You may need to update with instcat.sql.  What
errors do you get?

Quote:
>       when we upgrade ODBC driver from 3.5 to 3.7, we can't connect with ADO
> 1.5, MSSQL is 7.0, what's the problem ?  Must we use ADO 2.0?

 Neil Pike MVP/MCSE.  Protech Computing Ltd
 (Please reply only to newsgroups)
 For SQL FAQ entries see

 or www.ntfaq.com/sql.html (+ ntfaq download)
 or http://www.swynk.com/faq/sql/sqlserverfaq.asp
 or http://www.sql-server.co.uk


Sun, 17 Feb 2002 03:00:00 GMT  
 ODBC ver. 3.7 and ADO 1.5 problem
Hi: Neil

    the error message is :
           run-time error: '-2147217843'(80040e4d):
           [Microsoft][ODBC SQL Server Drive][SQL Server] login failed

   what's the instcat.sql, where can I find it, how do I update it?

thank you very much

George

Quote:

>George - it should work ok.  You may need to update with instcat.sql.  What
>errors do you get?

>>       when we upgrade ODBC driver from 3.5 to 3.7, we can't connect with
ADO
>> 1.5, MSSQL is 7.0, what's the problem ?  Must we use ADO 2.0?

> Neil Pike MVP/MCSE.  Protech Computing Ltd
> (Please reply only to newsgroups)
> For SQL FAQ entries see

> or www.ntfaq.com/sql.html (+ ntfaq download)
> or http://www.swynk.com/faq/sql/sqlserverfaq.asp
> or http://www.sql-server.co.uk



Mon, 18 Feb 2002 03:00:00 GMT  
 ODBC ver. 3.7 and ADO 1.5 problem
George - you'll find instcat.sql inside MDAC - www.microsoft.com/data.

 But your error is fairly clear :-

Quote:
>     the error message is :
>            run-time error: '-2147217843'(80040e4d):
>            [Microsoft][ODBC SQL Server Drive][SQL Server] login failed

>    what's the instcat.sql, where can I find it, how do I update it?

Q.     I am getting a SQL Server error message "login failed", even though I am
sure I am using the right userid.
(v1.0  08.10.1998)

A. This is a pretty common one.  The login failed message is unfortunately a
generic message that should really say "unable to make connection" as it often
isn't a logon validation problem.  Try the following :-

1.  Remember it is the SQL Server login and password that SQL is expecting, NOT
an NT one.  The default SQL userid and password is "sa" and no password.

2.  It could be a "network" connection problem.  If you're registering a local
server with SQL EM then register it as "." without the quotes.  Try connecting
using whichever tool locally on the server without specifying the server name -
this forces a local named-pipe connection.

3.  It could be that SQL is out of connections.  Check the <sql>\log\errorlog
file for this.  Check if SQL has been started in single-user mode.  Check the
following registry key :-

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\Parameters

Under here there are SQLArg0, SQLArg1...... type parameters - the single-user
one is "/m".  Remove it if it is there.

4.  Finally, if you're sure that the userid is correct (and remember SQL can be
case-sensitive) then try disabling any virus-checking software as this may be
interfering.

 Neil Pike MVP/MCSE.  Protech Computing Ltd
 (Please reply only to newsgroups)
 For SQL FAQ entries see

 or www.ntfaq.com/sql.html (+ ntfaq download)
 or http://www.swynk.com/faq/sql/sqlserverfaq.asp
 or http://www.sql-server.co.uk



Tue, 19 Feb 2002 03:00:00 GMT  
 
 [ 4 post ] 

 Relevant Pages 

1. Problem writing to Access 97 DB with ADO 1.5 and 2.1 (using ODBC)

2. VB5EE setup wizard and mdac 1.5 (ado 1.5) problem

3. Are there problems with eVB and AS 3.7

4. Please HELP! ADO 1.0 to 1.5 problem

5. Problem with ADO 1.5 and Access 8.0

6. VB5, ADO 1.5, SQL Server 6.5 problem

7. VB5, ADO 1.5, SQL Server 6.5 problem

8. Please HELP! ADO 1.0 to 1.5 problem

9. LDAP connection with ADO 1.5

10. ADO 1.5 CMD error when executing Stored Procedures??

11. ADO 1.5, Where do u get it ?

12. LDAP connection with ADO 1.5

 

 
Powered by phpBB® Forum Software