Ado Command Object reports error 
Author Message
 Ado Command Object reports error

Hi All
 I have a problem when i package my application and install in a another
machine(Non Development machine).

The issue is i'm making use of ADO 2.6 type library for accessing
database and sp2 of w2k is installed on developement machine.When i
package this and install it on devlopment machine things go smoothly.

But when i try to run it an non-development machine ,the exe fails at a
point where i invoke a stored procedure using  Ado.Command
object(cmd.Execute ,, adExecuteNorecords)
It fails at this point reporting an error that(Type name is unknown or
Invalid).
Can anyone suggest a solution or what the problem is all about

Thanking in Advance

*** Sent via Developersdex http://www.*-*-*.com/ ***
Don't just participate in USENET...get rewarded for it!



Fri, 28 Jan 2005 12:30:20 GMT  
 Ado Command Object reports error
Hi,

Do you have any parameters in your Command? It is possible, then something
wrong with parameters.

--
Val Mazur
Microsoft MVP


Quote:
> Hi All
>  I have a problem when i package my application and install in a another
> machine(Non Development machine).

> The issue is i'm making use of ADO 2.6 type library for accessing
> database and sp2 of w2k is installed on developement machine.When i
> package this and install it on devlopment machine things go smoothly.

> But when i try to run it an non-development machine ,the exe fails at a
> point where i invoke a stored procedure using  Ado.Command
> object(cmd.Execute ,, adExecuteNorecords)
> It fails at this point reporting an error that(Type name is unknown or
> Invalid).
> Can anyone suggest a solution or what the problem is all about

> Thanking in Advance

> *** Sent via Developersdex http://www.developersdex.com ***
> Don't just participate in USENET...get rewarded for it!



Fri, 28 Jan 2005 21:37:04 GMT  
 Ado Command Object reports error
Hi
 I do have set of input and output parameters,which are of integer and
varchar type.

If the problem is with parameters then why is it not reporting any error
in other occassions but only when i install the package in a
non-developement machines where there is still vb.

Pour in your valuable suggestions

Thankx in advance

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!



Sat, 29 Jan 2005 11:54:46 GMT  
 Ado Command Object reports error
Hi,

It could be that parameters were bound to stored procedure in wrong
sequence. See next KB to find out how to check your parameters. Let us know
if it helps

http://support.microsoft.com/default.aspx?scid=kb;en-us;Q181199

--
Val Mazur
Microsoft MVP


Quote:
> Hi
>  I do have set of input and output parameters,which are of integer and
> varchar type.

> If the problem is with parameters then why is it not reporting any error
> in other occassions but only when i install the package in a
> non-developement machines where there is still vb.

> Pour in your valuable suggestions

> Thankx in advance

> *** Sent via Developersdex http://www.developersdex.com ***
> Don't just participate in USENET...get rewarded for it!



Sat, 29 Jan 2005 19:56:15 GMT  
 Ado Command Object reports error
Hi
 i checked with that sample from msdn but it doesn't help the issue.I
still emphazize that i'm facing this problem only in few non-development
workstations or few workstations where there is vb still.It works fine
with all devleopment workstations.

Has this got any link with type libraries or ado library.

Pls suggest some solution

Thankx

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!



Sun, 30 Jan 2005 16:58:05 GMT  
 Ado Command Object reports error
Hi,

Try to run Component Checker utility from MDAC to see if your version of
MDAC is fine. Also, what types of parameters are you using in your stored
procedure and how did you define them in your VB code?

--
Val Mazur
Microsoft MVP


Quote:
> Hi
>  i checked with that sample from msdn but it doesn't help the issue.I
> still emphazize that i'm facing this problem only in few non-development
> workstations or few workstations where there is vb still.It works fine
> with all devleopment workstations.

> Has this got any link with type libraries or ado library.

> Pls suggest some solution

> Thankx

> *** Sent via Developersdex http://www.developersdex.com ***
> Don't just participate in USENET...get rewarded for it!



Sun, 30 Jan 2005 19:43:13 GMT  
 
 [ 6 post ] 

 Relevant Pages 

1. Error Using ADO Command object

2. Error using the Command-object of ADO

3. ADO Command Object Error 3711 Invalid Operation

4. ADO Command object and MSShape commands

5. Using the ADO Command Object to send an Execute command

6. ADO Command Object using Multiple Connection Objects

7. ado errors not trapped by vb error object???

8. Setting the recordset for a form with an ADO command object

9. Setting the ActiveConnection property of a Command Object (ADO 2.7)

10. Passing variables to an ADO Command or RecordSet Object in another frame

11. connection problem with ADO command object ......

12. Command Object Problem in ADO

 

 
Powered by phpBB® Forum Software