Deleted/Marked records in FoxPro 
Author Message
 Deleted/Marked records in FoxPro

I am currently using VB 4.0 and FoxPro 2.6 as my database.  My data is
stored on the network.  I found through testing if I have some deleted
records in the middle of good records that the Select statement or a Seek
statement will not go pass the deleted records which causes major problems.
 If I pack the database then my application runs fine.  Is there something
I need to change in the Registry or within my application.  I can't be
packing the databases all the time.  Has anyone come acrosss this problem?
Does anyone have an answer for me?  The surprise is that it doesn't happen
if I run the data locally.

Help,

Eve P.



Sat, 18 Dec 1999 03:00:00 GMT  
 Deleted/Marked records in FoxPro

I tried that by pointing to the VB.INI and inserting the [dBase ISAM]
deleted =on.  I also went into the registry to
HKEY_LOCAL_MACHINE\Software\Microsoft\Jet\3.0\Engines\xbase Deleted = 01 or
00 to see if that would help.  Everything I tried respond the same way.
The weird thing is that it doesn't always happen.  I need to do alittle
more investigation, but I think if there are so many records deleted in a
row then that causes my problem as  I have stated in the first remark.  If
you have any other idea I would be happy to try them.

Eve P



Sun, 19 Dec 1999 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. FoxPro databases and records marked for deletion

2. Dbase record marked as deleted

3. delete records marked with checkboxes

4. dbase delete marked records

5. Cannot add record to Visual Foxpro table after deleting all records in table

6. Foxpro database (Deleted Records)

7. Foxpro Deleted Records

8. deleting records from a Foxpro database

9. Handling A deleted Foxpro Record

10. Cannot delete record on FoxPro 2.5 DB

11. Accessing Foxpro dbf - deleted records

12. Deleted Records Under FoxPro 2.6

 

 
Powered by phpBB® Forum Software