VB5, Oracle 73 and CR 4.6 
Author Message
 VB5, Oracle 73 and CR 4.6

All,

I am using the above combination and am having a problem.

I have created a report in the CR Designer and it accesses the database
tables and create the report fine in design mode.

But, When I try to write the VB code to call the report it fails either
with.

Run-Time Error 20536
Unable to logon to the server
    on this code
            iConnectID = crptBatchReport.LogOnServer("PDSodbc.dll",
"ANADV1", "ANADV1", "R276DBO", "R276DBO")

or
Run-Time Error 20527
SQL Server error
    on this code
            sConnect = "DSN=ANADV1;UID=R276DBO;PWD=R276PWD;DSQ="
            crptBatchReport.Connect = sConnect
            crptBatchReport.SQLQuery = sql
            crptBatchReport.PrintReport

            crptBatchReport.Action = 1

I also tried this line with the same results (Run-Time Error 20527)
    sConnect = "ODBC;DSN=ANADV1;UID=R276DBO;PWD=R276PWD"

I pulled some KB articles from from the CR web site and it mentioned some
entries that should be in the
ODBC.INI file for CRORA or CROR7. There are no entries like these in my
ODBC.INI file or in the Registry (Win95). Is there a config or .reg file I
need to run to get this going?

TIA,
Richard Beyea



Tue, 03 Oct 2000 03:00:00 GMT  
 VB5, Oracle 73 and CR 4.6

Ok. I figured it out. The WHERE clause I was passing to the .SQLQuery
property was bad.

Quote:

>All,

>I am using the above combination and am having a problem.

>I have created a report in the CR Designer and it accesses the database
>tables and create the report fine in design mode.

>But, When I try to write the VB code to call the report it fails either
>with.

>Run-Time Error 20536
>Unable to logon to the server
>    on this code
>            iConnectID = crptBatchReport.LogOnServer("PDSodbc.dll",
>"ANADV1", "ANADV1", "R276DBO", "R276DBO")

>or
>Run-Time Error 20527
>SQL Server error
>    on this code
>            sConnect = "DSN=ANADV1;UID=R276DBO;PWD=R276PWD;DSQ="
>            crptBatchReport.Connect = sConnect
>            crptBatchReport.SQLQuery = sql
>            crptBatchReport.PrintReport

>            crptBatchReport.Action = 1

>I also tried this line with the same results (Run-Time Error 20527)
>    sConnect = "ODBC;DSN=ANADV1;UID=R276DBO;PWD=R276PWD"

>I pulled some KB articles from from the CR web site and it mentioned some
>entries that should be in the
>ODBC.INI file for CRORA or CROR7. There are no entries like these in my
>ODBC.INI file or in the Registry (Win95). Is there a config or .reg file I
>need to run to get this going?

>TIA,
>Richard Beyea




Tue, 03 Oct 2000 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Trouble with ADO in VB5 to Oracle 7.33, using the Oracle 73 driver

2. Trouble with ADO in VB5 with Oracle 7.33 and Oracle 73 driver

3. CR 4.6 to Oracle DB

4. CR 4.6 ODBC-oracle Stored Procedures

5. CR 4.6 and ORACLE Number datatype

6. VB4 connecting to Oracle 73

7. Visual Basic connecting to Oracle 73

8. Upgrading Oracle 73 to 8

9. Microsoft ODBC for Oracle v 2.73.728303 issue with WINNT

10. MaxRows - Oracle 2.73.726900 (MDAC) Driver Help

11. CR 4.6 shipped with VB5 question - How to tell when report is unloaded in Visual Basic

12. CR 4.6 shipped with VB5 question - referencing group subtotals

 

 
Powered by phpBB® Forum Software