Problem passing parameters to MSSQL Svr stored proc using API 
Author Message
 Problem passing parameters to MSSQL Svr stored proc using API

I have a report (CRW v5) based on a sql server (6.5) stored proc and I want
to pass in two dates using the PESetNthParam API call, but it fails with
Invalid stored procedure parameter no matter what date format I try.

Anyone done this successfully?

Cheers
Richard Garner

(Personal replies, please remove nospam from address before sending e-mail)



Sun, 29 Oct 2000 03:00:00 GMT  
 Problem passing parameters to MSSQL Svr stored proc using API



Quote:
> I have a report (CRW v5) based on a sql server (6.5) stored proc and I want
> to pass in two dates using the PESetNthParam API call, but it fails with
> Invalid stored procedure parameter no matter what date format I try.

> Anyone done this successfully?

> Cheers
> Richard Garner

> (Personal replies, please remove nospam from address before sending e-mail)

try formatting the date as follows:

yyyy-mm-dd hh:mm:ss.000

the .000 seems to be necessary, but i'm not sure what unit of time it
represents.  also notice that its ".000" not ":000".

hope this helps.

gary



Tue, 31 Oct 2000 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. How to pass parameter to DataEnvironment (stored proc)

2. Passing parameter from VB6 to a CRW report based on a Stored Proc

3. Passing DATETIME parameter to stored proc

4. Passing DATETIME parameter to stored proc

5. Passing DATETIME parameter to stored proc

6. Performance of Stored Proc Parameter Passing

7. Passing DATETIME parameter to stored proc

8. passing stored proc parameters to crystal reports

9. Passing Parameters to stored parameter queries using VB 5's Data Controls

10. Help - Using Sql Server Stored Proc with parameters

11. stored proc parameters problem, MFC

12. problem with crystal report using sybase stored proc

 

 
Powered by phpBB® Forum Software