!! Trouble Using Crystal Data Objects on Crystal Rep 6.0 
Author Message
 !! Trouble Using Crystal Data Objects on Crystal Rep 6.0

Dear Expert,

We have some codes which retrieve any specified data from ADO recordset and
return them to an array of variants,
the array need to be assigned to the Rowset object of the Crystal Data
Object.
but we've got an error

Runtime error "1001":

Type mismatch in Parameter. Must be an array object.

with the "yellow pointer" break at position marked by ">" (greather than)
below,

The codes are :
.........

    If odata.RetrieveAllData(sQryStr, ArrN, ArrV, DsnCommon) = 0 Then
        Dim JmlRec As Integer
        JmlRec = UBound(ArrV) \ 3
        ReDim Rows(1 To 3)
        n = 0
        For i = 0 To JmlRec
            Rows(1) = CStr(ArrV(n))
            Rows(2) = CStr(ArrV(n + 1))
            Rows(3) = CStr(ArrV(n + 2))
            n = n + 3

Quote:
>            CDOSet.AddRows Rows

        Next i

    End If

Regards,




Tue, 07 Aug 2001 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. how do i print just one record using crystal rep 6.0

2. Trouble porting Crystal Rep. from VB4 to VB5

3. Trouble re-using data in a Crystal Report

4. Crystal Reports ANd VB 6.0 Printing reports using CRPEAUTO Object, specifying paper orientation problem

5. Using the CDO (Crystal Data Object) gives VB error 429

6. crystal 8.0 .ocx & crystal 6.0 .rpt

7. Crystal Reports 4.5 to Seagate Crystal Info 6.0 API

8. Crystal Report 4.6 in Crystal Report 6.0

9. VB5 Crystal Rep OLE error

10. Complicated Partial Sums With Crystal Rep. :\

11. Crystal rep. printing diferent groups in diferent colors

12. Please Help: Crystal Rep.:weird problem !

 

 
Powered by phpBB® Forum Software