Running Crystal Report Web Component Server and SQL Server on different machines 
Author Message
 Running Crystal Report Web Component Server and SQL Server on different machines

I used to run Crystal Report Web Component Server and SQL Server on the same
machine without any problem. However, when I try to put the sql server on
another computer, I always get the following error message :-

Error Type:
cpeaut32 (0x800A5038)
Error in File : Unable to connect: incorrect log on parameters.
/wwc/include/reportTop.htm, line 29

The code fragment of the program encountered error are :-

 ' CREATE THE APPLICATION OBJECT
 If Not IsObject (session("oApp")) Then
  Set session("oApp") = Server.CreateObject("Crystal.CRPE.Application")
 End If

 ' CREATE THE REPORT OBJECT
 '
 'The Report object is created by calling the Application object's
OpenReport method.

 Path = Request.ServerVariables("PATH_TRANSLATED")
 While (Right(Path, 1) <> "\" And Len(Path) <> 0)
  iLen = Len(Path) - 1
  Path = Left(Path, iLen)
 Wend

  session("oApp").LogonServer "p2ssql.dll", "wwc_srv", "dbwwc", "sa" ,
"whoami"   <<<<--- Error Line

 'OPEN THE REPORT
 Set session("oRpt") = session("oApp").OpenReport(path & reportName, 1)

 set session("oRptOptions") = Session("oRpt").Options
 session("oRptOptions").MorePrintEngineErrorMessages = 0

 ' Creates the Report Parameter Collection
 set rptParmCollection = Session("oRpt").Parameterfields

 For rptParmIdx = 0 To uBound(rptParmArr)
  rptParmCollection.item(rptParmIdx + 1).setCurrentValue
rptParmArr(rptParmIdx)
 Next

May someone help me please? Thanks!



Tue, 10 Aug 2004 16:34:52 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Crystal Web Reports Server 7 string parameters arent being passed to SQL Server StoredProc

2. Web Component Server and SQL Server Problem

3. Newbie question - installing Crystal Reports web components server

4. running Active Server on NT Server 4.0 for Crystal Reports

5. Looking for Web Host running Crystal Web Server

6. Crystal report 6, Web Report Server, inetInfo (IIS) 100% CPU-usage problem

7. Crystal 8.5 web component server and stored procedures

8. Seagate Crystal 8.0 hangs using web component server

9. Running VB exe from on SQL server machine fails

10. Running VB exe from on SQL server machine fails

11. Running VB exe from on SQL server machine fails

12. Running VB exe from on SQL server machine fails

 

 
Powered by phpBB® Forum Software