Problem refreshing report data in crystal reports 4.6 
Author Message
 Problem refreshing report data in crystal reports 4.6

I am having problems refreshing the data in Crystal Reports 4.6.
I have read the other messages on this board and they say to use
the discardsaveddata method of the report control and set it to
true. I did this and when i go to click on the button to run the
report nothing happens (the mouse pointer quickly goes to the
hourglass icon and then back to the normal mouse pointer). When
i set the discardsaveddata to false i get the report when clicking
on the button but i get OLD data, data that was there when i first
created the report. I also went into the options in crystal report
and CHECKED the Refresh Data On Every Print option and UNCHECKED the
Save Data With Closed Report. I am currently using an access database
to store the information and it is from this database the report
data is extracted.

Any help would be greatly appreciated,

Thankyou!

Tim :-)



Sat, 09 Oct 2004 11:40:19 GMT  
 Problem refreshing report data in crystal reports 4.6
In Visual Basic, and I'm not sure if this is how you are doing it, but as
you are working with an instance of an object, you have to create and
destroy the object as and when you use it.

E.g.

at the beginning of my program I have

Dim Report As New CrystalReports1

Set Report = New CrystalReport1

Then at my Form Unload section I say

Set Report = Nothing

This got around my problem of data not updating.

Hope this helps

Brett


Quote:
> I am having problems refreshing the data in crystal reports 4.6.
> I have read the other messages on this board and they say to use
> the discardsaveddata method of the report control and set it to
> true. I did this and when i go to click on the button to run the
> report nothing happens (the mouse pointer quickly goes to the
> hourglass icon and then back to the normal mouse pointer). When
> i set the discardsaveddata to false i get the report when clicking
> on the button but i get OLD data, data that was there when i first
> created the report. I also went into the options in crystal report
> and CHECKED the Refresh Data On Every Print option and UNCHECKED the
> Save Data With Closed Report. I am currently using an access database
> to store the information and it is from this database the report
> data is extracted.

> Any help would be greatly appreciated,

> Thankyou!

> Tim :-)



Sat, 09 Oct 2004 18:00:30 GMT  
 Problem refreshing report data in crystal reports 4.6
Hello,
I am using Crystal report 6 with VB6. I have the same problem too. Sometimes
there is no need to click the refresh button & sometimes I have to click the
Refresh btn in order to get the data displayed.
I did CHECKED the Refresh Data option during design time.

I wonder if anybody using the latest version of crystal rpt 8 have the same
problem like this or not

.Anybody out there can help.....

Here is the code :

    crptDO.ReportFileName = App.Path & "\report\DO.rpt"
    crptDO.WindowShowPrintSetupBtn = True
    If glb_HQ_yn = True Then
       crptDO.Connect = "DSN=bts;UID=sa;PWD=nopassword"
    Else
       crptDO.Connect = "DSN=bts_MDB;UID=sa;PWD=nopassword"
    End If
    crptDO.WindowTitle = "Delivery Order"
    crptDO.WindowState = crptMaximized

    sql = " SELECT "
    sql = sql & " RPT_DO.SERIAL_NO, RPT_DO.MDL_CODE, RPT_DO.BRD_CODE,
RPT_DO.OTL_NAME, RPT_DO.OTL_ADDR, RPT_DO.DELIV_NO,"
    sql = sql & " DLR_DEALER_MASTER.DLR_NAME , DLR_DEALER_MASTER.DLR_ADDR_1,
DLR_DEALER_MASTER.DLR_ADDR_2, DLR_DEALER_MASTER.DLR_ADDR_3,
DLR_DEALER_MASTER.DLR_ADDR_4, DLR_DEALER_MASTER.DLR_CONTACT"
    sql = sql & " From "
    sql = sql & "     RPT_DO RPT_DO INNER JOIN DLR_DEALER_MASTER
DLR_DEALER_MASTER ON"
    sql = sql & "     RPT_DO.DLR_CODE = DLR_DEALER_MASTER.DLR_CODE"
    sql = sql & " where RPT_DO.DELIV_NO='" & tDelivNo & "'"
    sql = sql & " and RPT_DO.MOD_BY='" & glb_EmpID & "'"
    sql = sql & " order by RPT_DO.BRD_CODE, RPT_DO.MDL_CODE,
RPT_DO.SERIAL_NO"
    crptDO.SQLQuery = sql
    crptDO.WindowShowRefreshBtn = True
    crptDO.Action = 1


Quote:
> I am having problems refreshing the data in crystal reports 4.6.
> I have read the other messages on this board and they say to use
> the discardsaveddata method of the report control and set it to
> true. I did this and when i go to click on the button to run the
> report nothing happens (the mouse pointer quickly goes to the
> hourglass icon and then back to the normal mouse pointer). When
> i set the discardsaveddata to false i get the report when clicking
> on the button but i get OLD data, data that was there when i first
> created the report. I also went into the options in crystal report
> and CHECKED the Refresh Data On Every Print option and UNCHECKED the
> Save Data With Closed Report. I am currently using an access database
> to store the information and it is from this database the report
> data is extracted.

> Any help would be greatly appreciated,

> Thankyou!

> Tim :-)



Sat, 09 Oct 2004 19:22:46 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Crystal Report 4.6 in Crystal Report 6.0

2. Crystal Reports 4.6 / VB5 Tables in Report

3. Crystal Report 4.6 and Sub report

4. SQLQuery in Crystal Report 4.6 : NOT FILTERING DATA (HELP)

5. Help !!! Problem with Crystal report 4.6

6. Printer ports problem in Crystal reports 4.6 - Please Help

7. VB6 + Crystal Report 4.6 problem

8. Crystal Reports 4.6 and Windows 2000 or XP problem

9. Problem loading Report Crystal 4.6

10. VB5 Crystal Report 4.6 Problem.

11. Crystal Report 4.6 Date Field Problem (Default to 12/30/99)

12. Crystal Report 4.6 - Grand Total Problem???

 

 
Powered by phpBB® Forum Software