Report Designer Component - Install problems 
Author Message
 Report Designer Component - Install problems

 I develop on NT 4 workstation with vb 6 and RDC 6 ... or whatever the
latest release is. I have created an install that works fine for displaying
a regular (crys32.ocx) Crystal Report ... The report gets sent one parameter
... runs the query correctly by hitting my ODBC connection to an Access
database and then displays the information in a chart within the report.

    My problem occurs because I want to use the Crystal component viewer
(crviewer.dll) so I change my code to display the report accordingly and got
crviewer.dll to register correctly (after some initial install problems with
msvfw32.dll) My program runs fine and displays the report component fine but
disapears as soon as I set it to my designer.

   After all this my log shows that error 713 ... "Application-defined or
object-defined error".

 I thought it would be my database setup but I am confused because the
designer is simply my crystal report imported (no changes) and one method of
viewing works ... so the db drivers should be install correctly. I am
thinking that it might have something to do with the different versions of
crviewer or some other viewing dll ... Anyone have suggestions? And yes I've
even printed out the list of files that are installed for RDC and every one
of those is installed.

 -Patrick



Mon, 03 Dec 2001 03:00:00 GMT  
 Report Designer Component - Install problems
I develop in a Win 95 machine and have been experiencing the same
problem.
But only in the VB enviroment. The compiled version (EXE file) runs OK.

I think it has something to do with the viewer. I have two versions in
my machine because I first intalled RDC then Crystal 6.0.
Although both versions are exactly the same in terms of date, size etc,
the viewer looks different. One on them has the Crystal logo on the top
right corner and the other doesn't.

If anyone knows what is wrong, speak up, please.

Quote:
-----Original Message-----

 I develop on NT 4 workstation with vb 6 and RDC 6 ... or whatever the
latest release is. I have created an install that works fine for
displaying
a regular (crys32.ocx) Crystal report ... The report gets sent one
parameter
... runs the query correctly by hitting my ODBC connection to an Access
database and then displays the information in a chart within the report.

    My problem occurs because I want to use the Crystal component viewer
(crviewer.dll) so I change my code to display the report accordingly and
got
crviewer.dll to register correctly (after some initial install problems
with
msvfw32.dll) My program runs fine and displays the report component fine
but
disapears as soon as I set it to my designer.

   After all this my log shows that error 713 ... "Application-defined
or
object-defined error".

 I thought it would be my database setup but I am confused because the
designer is simply my crystal report imported (no changes) and one
method of
viewing works ... so the db drivers should be install correctly. I am
thinking that it might have something to do with the different versions
of
crviewer or some other viewing dll ... Anyone have suggestions? And yes
I've
even printed out the list of files that are installed for RDC and every
one
of those is installed.

 -Patrick



Tue, 04 Dec 2001 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. PDSMON.DLL problem with Report Designer Component

2. Report Designer Component Problem With RecordSelectionFormula

3. Problem selecting records using ADO/Report designer component 6

4. Problem selecting records using ADO/Report designer component 6

5. Crystal Reports 6 Report Designer Component

6. Crystal Reports Report Designer Component

7. Crystal Report Designer Component (Previewing a report.)

8. Crystal Reports "Report Designer Component"

9. Crystal Report Designer Component (Previewing a report.)

10. Designer Component 6.0 not installing under W2K

11. Designer Component 6.0 Install Registry Issue with VB 6.0 SP1

12. VB6 Learning Edition Install Problems when searching for installed components

 

 
Powered by phpBB® Forum Software