result = 0 on PELogOnServer 
Author Message
 result = 0 on PELogOnServer

heeelp.. I am getting a 0 in my result after trying to log on.. I can
connect to the db using VB in the forms but not thru crystal's
PELogOnServer function..


My code is simple and as follows...

Dim result%
Dim LogOnInfo As PELogOnInfo

result% = PEOpenEngine()
If result% = 0 Then
    MsgBox "Could not start the report engine. Execution must halt.",
vbOKOnly + vbCritical, "Serious Error"
    End
End If

LogOnInfo.StructSize = PE_SIZEOF_LOGON_INFO
LogOnInfo.ServerName = "Venus" & Chr$(0)
LogOnInfo.DatabaseName = "PDE Edna" & Chr$(0)
LogOnInfo.UserId = "xxx_xxxxxxxx" & Chr$(0)
LogOnInfo.Password = "xxxxxxxx" & Chr$(0)

result% = PELogOnServer("p2sodbc.dll", LogOnInfo)

Sent via Deja.com http://www.*-*-*.com/
Before you buy.



Tue, 11 Mar 2003 03:00:00 GMT  
 result = 0 on PELogOnServer
BTW, I am using a SQL Server Database and I do have both a user and
system ODBC connections defined from the control panel.. thx, Corey

Sent via Deja.com http://www.deja.com/
Before you buy.



Tue, 11 Mar 2003 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Error 536 (Incorrect logon parameters) when trying to logon to a access-db via PELogonServer

2. PELogOnServer problem

3. Native code results different from p-code results

4. Sort query results according to criteria from different table

5. Err 3759 Scaling of decimal value resulted in data truncation

6. Displaying CorssTab Query results in combination with VBA code

7. Searching Result

8. Unpredictable Query Results

9. How to close a query window result on No data

10. inserting the result of qry into a table through vba

11. Function not returning expected results.

12. Append VB result to a table.

 

 
Powered by phpBB® Forum Software