Automation -214xxxxxx error or Mtheod ~ of ~ object failed error 
Author Message
 Automation -214xxxxxx error or Mtheod ~ of ~ object failed error

I recieve this error when trying to print a report to a Lexmark E
series or HP 5XXX printers.
This error seems to follow these types of printers.

I have tried multiple work arounds for this issue including switching
from the active-x control to calling the automation server directly.
This seemed to fix some of the automation errors on other Lexamark and
HP printers, but the above printer problems remain.
I noticed that prior to switching from the active-x control to the
automation objects I could intall a standard generic printer that
prints to a file and some of the installs began to work fine. I would
also like to note that I never used the generic printer I  installed
but it seemed have an effect of fixing printing problem with the HP
and Lexmark printers installed on the same machine.
I have also made sure that the printers being used have the latest
drivers installed.

If I show the preview and click the printer button from the preview
window they will print fine in most cases.

Again, the same code will work with other printers just fine with no
changes, even on the same computer.

This leads me to beleive that this is a Crytal issue all the way.

I have not posted an example of my code becaue my code has come
directly out of Crystals Developer help file.

I guess I am more looking to see if anyone else has run in to similar
issues and has noticed a common fix to resolve these issues.

Steve



Tue, 27 Jan 2004 05:29:06 GMT  
 Automation -214xxxxxx error or Mtheod ~ of ~ object failed error
This may not necessarily be a Crystal problem.  Are you using ADO?  I
had this error using ADO with Crystal.  It turned out to be a failure
on the part of ADO somehow.  Check out:

http://www.promodag.com/support/reports/FAQ/topics/method__~__of_obje...

Also, a co-worker of mine had this problem and suggested this as a
possible problem: if you are using parameters within sub-reports to
link data for that subreport, make sure that you set the subreport
data source with data that the subreport can link to.  If it can't
then method of object error.

Hope this helps,
Dan

Quote:

> I recieve this error when trying to print a report to a Lexmark E
> series or HP 5XXX printers.
> This error seems to follow these types of printers.

> I have tried multiple work arounds for this issue including switching
> from the active-x control to calling the automation server directly.
> This seemed to fix some of the automation errors on other Lexamark and
> HP printers, but the above printer problems remain.
> I noticed that prior to switching from the active-x control to the
> automation objects I could intall a standard generic printer that
> prints to a file and some of the installs began to work fine. I would
> also like to note that I never used the generic printer I  installed
> but it seemed have an effect of fixing printing problem with the HP
> and Lexmark printers installed on the same machine.
> I have also made sure that the printers being used have the latest
> drivers installed.

> If I show the preview and click the printer button from the preview
> window they will print fine in most cases.

> Again, the same code will work with other printers just fine with no
> changes, even on the same computer.

> This leads me to beleive that this is a Crytal issue all the way.

> I have not posted an example of my code becaue my code has come
> directly out of Crystals Developer help file.

> I guess I am more looking to see if anyone else has run in to similar
> issues and has noticed a common fix to resolve these issues.

> Steve



Sat, 31 Jan 2004 21:31:40 GMT  
 Automation -214xxxxxx error or Mtheod ~ of ~ object failed error
I got this error message when I try to open MS Analysis Services 2000 Management Console.  After I applied the service pak, the problem went away.

Perhaps something similar is required in your situation.

Craig Buchanan

I recieve this error when trying to print a report to a Lexmark E
series or HP 5XXX printers.
This error seems to follow these types of printers.

I have tried multiple work arounds for this issue including switching
from the active-x control to calling the automation server directly.
This seemed to fix some of the automation errors on other Lexamark and
HP printers, but the above printer problems remain.
I noticed that prior to switching from the active-x control to the
automation objects I could intall a standard generic printer that
prints to a file and some of the installs began to work fine. I would
also like to note that I never used the generic printer I  installed
but it seemed have an effect of fixing printing problem with the HP
and Lexmark printers installed on the same machine.
I have also made sure that the printers being used have the latest
drivers installed.

If I show the preview and click the printer button from the preview
window they will print fine in most cases.

Again, the same code will work with other printers just fine with no
changes, even on the same computer.

This leads me to beleive that this is a Crytal issue all the way.

I have not posted an example of my code becaue my code has come
directly out of Crystals Developer help file.

I guess I am more looking to see if anyone else has run in to similar
issues and has noticed a common fix to resolve these issues.

Steve

______________________________________________________________________________
Crystal Decisions USENET forums at http://www.cogniza.com/support/forums



Mon, 02 Feb 2004 02:59:28 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. COM+ Automation Error/connection to the transaction manager failed Error/ Q331953

2. Compile error: Automation error, Error 32811: Unexpected error

3. Automation error... Error 424, Object Required

4. INet Error: Automation Error - The object invoked has disconnected from its clients

5. Compilation error: Automation Error (Error 440)

6. Run-time error '-2147417846 (8001010a)': Automation error (error 440)

7. Run-time error '-2147417846 (8001010a)': Automation error (error 440)

8. Report fails on some Win95 Clients (Automation error)

9. Run Time error -2147417848 Method Of Object Failed

10. Method Action of object CrystalCtrl failed Error ?

11. ERROR : METHOD OF OBJECT FAILED

12. random error (method execute of object _Connection failed)

 

 
Powered by phpBB® Forum Software