WebBrowser Control Problems 
Author Message
 WebBrowser Control Problems

I have a WebBrowser control in my form. I can load "locally" stored HTML
document within my "web browser control no problem.

My problem is that I am having NO LUCK reading data values stored in form
objects within my html page which is within the "WebBrowser" Control.

here is my code that I am attempting to use to retrieve/read a value from
within a form in my html document:
=========================
dim x as string

x = ctlWeb.Document.FormName.FormElement.value
===========================

NOTE: ctlWeb is the name I have given to my "WebBrowser" control that is in
my form.

however, I keep getting an error when I try to access this value. Has anyone
tackled this problem and come away with a solution?

TIA
victor



Mon, 14 Oct 2002 03:00:00 GMT  
 WebBrowser Control Problems
You'll have to look in the WebBrowser.Document.Forms for the right form. I
have a a source for filling the Altavista search form on my site
(http://vbpoint.cjb.net), I think it shouldn't be to hard to the reverse it.

If you can't figure out how to do get it working, you may contact me on the
email address listed on my site.

--
Stephan

My site: http://www.casema.net/~dolman/s/

Get PAID to surf the web for FREE:
http://www.alladvantage.com/go.asp?refid=ASB738

FREE VB Source: http://vbpoint.cjb.net/



Quote:
> I have a WebBrowser control in my form. I can load "locally" stored HTML
> document within my "web browser control no problem.

> My problem is that I am having NO LUCK reading data values stored in form
> objects within my html page which is within the "WebBrowser" Control.

> here is my code that I am attempting to use to retrieve/read a value from
> within a form in my html document:
> =========================
> dim x as string

> x = ctlWeb.Document.FormName.FormElement.value
> ===========================

> NOTE: ctlWeb is the name I have given to my "WebBrowser" control that is
in
> my form.

> however, I keep getting an error when I try to access this value. Has
anyone
> tackled this problem and come away with a solution?

> TIA
> victor



Thu, 17 Oct 2002 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Webbrowser control problem with IE

2. WebBrowser control problem with IE6 (I think...)

3. WebBrowser Control Problem

4. WebBrowser Control Problem , simulating submit button

5. WebBrowser Control Problems

6. WebBrowser Control Problem , simulating submit button

7. webBrowser Control problem

8. WebBrowser control problem?

9. WebBrowser Control Problem , simulating submit button

10. Webbrowser control problem

11. WebBrowser Control problems...

12. WebBrowser control problem

 

 
Powered by phpBB® Forum Software