Winsock error 10048 "Address in use" 
Author Message
 Winsock error 10048 "Address in use"

Hi,
I'm trying to use Winsock control for TCP programming (VB5 & Win95). Any
try to connect, disconnect and re-connect the same port is being reject
with error core 10048 - "Address in use". If I'm waiting before the
re-connect several second it will be OK.

Regards, Barak



Mon, 19 Nov 2001 03:00:00 GMT  
 Winsock error 10048 "Address in use"
Try asigning te port property to 0 after each disconection.
I have worked for me....if not for your...send me a mail and I will help
you...I know that problem.

--

                       \\~ ~//

        ----------o00o-(_)-o00o-------------
Mauricio Mrquez Anze
United Nations Development Programme

Quote:
> Hi,
> I'm trying to use Winsock control for TCP programming (VB5 & Win95). Any
> try to connect, disconnect and re-connect the same port is being reject
> with error core 10048 - "Address in use". If I'm waiting before the
> re-connect several second it will be OK.

> Regards, Barak



Tue, 20 Nov 2001 03:00:00 GMT  
 Winsock error 10048 "Address in use"
I had tried that, but its still not working.
I even make sure that the port is closed before initiate
the connect process.
Barak.
Quote:

> Try asigning te port property to 0 after each disconection.
> I have worked for me....if not for your...send me a mail and I will help
> you...I know that problem.

> --

>                        \\~ ~//

>         ----------o00o-(_)-o00o-------------
> Mauricio Mrquez Anze
> United Nations Development Programme


> > Hi,
> > I'm trying to use Winsock control for TCP programming (VB5 & Win95). Any
> > try to connect, disconnect and re-connect the same port is being reject
> > with error core 10048 - "Address in use". If I'm waiting before the
> > re-connect several second it will be OK.

> > Regards, Barak



Fri, 23 Nov 2001 03:00:00 GMT  
 Winsock error 10048 "Address in use"
Why don't you send me the code you are using...and I will tune up it for
you....!!!

--

                       \\~ ~//

        ----------o00o-(_)-o00o-------------
Mauricio Mrquez Anze
United Nations Development Programme

Quote:
> I had tried that, but its still not working.
> I even make sure that the port is closed before initiate
> the connect process.
> Barak.


> > Try asigning te port property to 0 after each disconection.
> > I have worked for me....if not for your...send me a mail and I will help
> > you...I know that problem.

> > --

> >                        \\~ ~//

> >         ----------o00o-(_)-o00o-------------
> > Mauricio Mrquez Anze
> > United Nations Development Programme


> > > Hi,
> > > I'm trying to use Winsock control for TCP programming (VB5 & Win95).
Any
> > > try to connect, disconnect and re-connect the same port is being
reject
> > > with error core 10048 - "Address in use". If I'm waiting before the
> > > re-connect several second it will be OK.

> > > Regards, Barak



Fri, 23 Nov 2001 03:00:00 GMT  
 Winsock error 10048 "Address in use"
Winsock property:
  Protocol = sckTCPProtocol
  RemoteHost = <my PC IP address>
  RemotePort = 8001
  LocalPort = 8001
*same app for client and server.

I'm trying to establish connection from a client application
to a server application.
What I'm not understand is, how can use LocalPort = 0
to connect dynamiclly to my server? The client should connect
to the same port which the server is "listing" to...

Regards, Barak.

Quote:

> Why don't you send me the code you are using...and I will tune up it for
> you....!!!

> --

>                        \\~ ~//

>         ----------o00o-(_)-o00o-------------
> Mauricio Mrquez Anze
> United Nations Development Programme


> > I had tried that, but its still not working.
> > I even make sure that the port is closed before initiate
> > the connect process.
> > Barak.


> > > Try asigning te port property to 0 after each disconection.
> > > I have worked for me....if not for your...send me a mail and I will help
> > > you...I know that problem.

> > > --

> > >                        \\~ ~//

> > >         ----------o00o-(_)-o00o-------------
> > > Mauricio Mrquez Anze
> > > United Nations Development Programme


> > > > Hi,
> > > > I'm trying to use Winsock control for TCP programming (VB5 & Win95).
> Any
> > > > try to connect, disconnect and re-connect the same port is being
> reject
> > > > with error core 10048 - "Address in use". If I'm waiting before the
> > > > re-connect several second it will be OK.

> > > > Regards, Barak



Fri, 30 Nov 2001 03:00:00 GMT  
 Winsock error 10048 "Address in use"
Winsock property:
  Protocol = sckTCPProtocol
  RemoteHost = <my PC IP address>
  RemotePort = 8001
  LocalPort = 8001
*same app for client and server.

I'm trying to establish connection from a client application
to a server application.
What I'm not understand is, how can use LocalPort = 0
to connect dynamiclly to my server? The client should connect
to the same port which the server is "listing" to...

Regards, Barak.

Quote:

> Why don't you send me the code you are using...and I will tune up it for
> you....!!!

> --

>                        \\~ ~//

>         ----------o00o-(_)-o00o-------------
> Mauricio Mrquez Anze
> United Nations Development Programme


> > I had tried that, but its still not working.
> > I even make sure that the port is closed before initiate
> > the connect process.
> > Barak.


> > > Try asigning te port property to 0 after each disconection.
> > > I have worked for me....if not for your...send me a mail and I will help
> > > you...I know that problem.

> > > --

> > >                        \\~ ~//

> > >         ----------o00o-(_)-o00o-------------
> > > Mauricio Mrquez Anze
> > > United Nations Development Programme


> > > > Hi,
> > > > I'm trying to use Winsock control for TCP programming (VB5 & Win95).
> Any
> > > > try to connect, disconnect and re-connect the same port is being
> reject
> > > > with error core 10048 - "Address in use". If I'm waiting before the
> > > > re-connect several second it will be OK.

> > > > Regards, Barak



Fri, 30 Nov 2001 03:00:00 GMT  
 
 [ 6 post ] 

 Relevant Pages 

1. Winsock error 10048 "Address in use"

2. Winsock OCX error - 10048 : Address in use.

3. Winsock OCX error - 10048 : Address in use.

4. Error '10048', Address In Use: Winsock Control

5. Winsock OCX error - 10048 : Address in use.

6. Error '10048', Address In Use: Winsock Control

7. VB5 Winsock - Error 10048 "Address in use"

8. VB5 Winsock - Error 10048 "Address in use"

9. VB5 Winsock - Error 10048 "Address in use"

10. VB5 Winsock - Error 10048 "Address in use"

11. VB5 Winsock - Error 10048 "Address in use"

12. Winsock Error "Address In Use"

 

 
Powered by phpBB® Forum Software