Strange tab behavior from custom control 
Author Message
 Strange tab behavior from custom control

Hello everyone,

I have an interesting situation occurring with an OCX control I created.

The control is very simple. It is a textbox that displays values from a
lookup table in a database after a user rightclicks.  In design mode, the
control worked great.

After I compiled the OCX, I created a new project for testing.  I added the
my control to a form and tested again.  Everything seemed okay.   But when I
added the control to a mdi child form and re-tested, a problem occurred.
After I lookup and return a value from the  table, pressing tab no longer
navigates thru the rest of the controls on the form.  This seems to happen
only if I return a value from the table.  If I cancel the lookup, the tab
key functions normally.

I have tried trapping the tab key, and also raising the keypress event on
the usercontrol, but neither have helped.

Does anyone have any ides of what could be going wrong.  Any help would be
greatly appreciated.

Thanks

Paul



Thu, 24 Aug 2000 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Strange Behavior From Custom Control

2. Custom Inbox handler - strange behavior

3. sstab strange tab behavior

4. strange behavior and useless properties (Upside-down tabs, Alignment, Moveable)

5. outlook view control & preview pane - strange behavior

6. strange behavior of control.focus() funktion. Need Help

7. Strange event behavior for datagrid control...

8. Strange behavior with parameterized querydef and data control.

9. Inet1 Control Strange Behavior

10. Strange behavior with parameterized querydef and data control.

11. strange label control behavior

12. Strange Behavior of Date Picker Control

 

 
Powered by phpBB® Forum Software